New Blu ray will not play

I have ripped several new Blu ray disks but WD says they are unsupported files. I have tried ripping to hard disk and ripping to ISO both with the same problem. I tried directly playing the m2ts but also with no success. The strange thing is I have some older Blu rays in ISO files that I ripped months ago, and these play perrfectly. I know the new rips are good because they play perfectly on my computer. I downloaded the latest firmware 2 or 3 weeks ago so it should all be up to date. DVD rips play from ISO perfectly, this is just a Blu ray problem. I don’t know what to try next.

Read the sticky posts.   They’re there for a reason.  :)

I read the sticky but it does not explain why the previously ripped m2ts files are ok. I assumed I had some other problem. Surely if it is just the firmware issue, then none of my Blu ray rips would play?

No, it’s a header-specific thing.   If different rips have different headers, it can be different results…

Thanks Tony but one last question. Is rolling back the firmware reliable? I have never had to do it before. I’m on 3.00.28 so may I assume 2.08.13 did not have this problem?

I don’t believe 2.08.13 had the same issue.