New 10TB easyStore External Harddrive won't turn on


#1

What happens: when I begin to plug in the power adapter into the drive the light quickly flashes once and immediately turns off. It never turns back on and the drive never spins up. This started happening right after I moved the USB from a USB hub, directly to my PC while everything was turned off. I moved everything back to how it originally was and it still won’t turn on. This exact same situation also applies to my 4TB My Book right now.

I’ve followed all of the suggested troubleshooting steps that I’ve seen on here: Place everything back how it originally was, change the power adapter, change data cords, plug it directly into the wall, plug USB directly into PC,etc. None of it has worked.

I just bought this Drive in November and it was working perfectly fine (a few minutes ago) until I switched it from my USB hub directly to the back of my PC.

I think I somehow might have fried my drives because as I stated earlier, I did the exact same thing at the exact same time with My Book and it is behaving the exact same way as my easyStore.

Any solution would be great.


#2

Hi YFB2011,

Your drives may have gone bad. You should contact WD Support from the link given below.

If the drive fails, you can create the RMA from the link given below if your drive is under warranty.


#3

or his USB Hub and/or USB Ports/IO on his PC have gone bad.

for Two hard drives to “go bad” at the same time, sounds very unlikely

I’d recommend the OP tries connecting them to a different PC … which from everything he’s described, he hasn’t tried.