Network shares don't shown correct

Hi @all,

i’ve some problems with one off my wd-sentinel. I’ve two Sentinels. One NAS-System works as active Storage system in my network and the other one consist copies from the active system. I use a simple batch to compare data’s between the active and the passive system. If data has been changed to the active system, the changes are transferred to the passive system.  The batch runs as task job every day.

Since the last Firmware Update to my passive Sentinel (it was my last change on the Device), I’ve some problems to reach samba shares on my active system. The Problem is, that the Explorer from passive System shows the Folder “Server Folders”  from active System as shared folder.  All my shared folders which was created in Dashboard will now shown as a simple subfolder from “ServerFolders” and not as shared folderes.

Before I’ve installed the new update, it works fine. The Explorer shows my shared folders correct like this:

\active-system\share1, \active-system\share2, …, \active-system\share9

And now show it like this:

\active-system\ServerFolders

share1, share2 etc. are shown as simple Subfolders.

Note: If the system correct works, the Folder “ServerFolders” aren’t shown as a share folder in the explorer.

The result of this problem is that all my files were deleted on the passive system because my batch script assumes that the files have been removed from the source.

To resolve this Problem I tried to reboot the Sentinels, unplug/plug the network cable, refresh DNS-zone data and AD. Finally, I removed the passive system from AD and tried to reach the shares on my active system as a client outside the Domain (after succeed authentication).

But the Problem still remains.

Hope you understand my bad English and give some ideas to resolve this problem. :cry:

Thanks a lot to all.

On your dash board of the active do you show the share folders (share1, share2…) on the main list? or do you just see a folder called serverfolder?

Is each shared folder shared? With the permission of the login your using.

Create a new folder in dashboard and tell us if it creates in inside the serverfolder or by itself.

Hey Santron,

on my dashbord are all folders shown in the main lsit. (view image, if you can).

active-system_s.png

Only my passive WD-Sentinel is one, which this problem has. When running the Command \active-System from a clientsystem (win7), there’s no problem and it works normal. I can see all my network shares.

Thanks for helping.

Have you tried creating new share folders outside the serverfolder then copy the contents over.

It is to despair. I created a new shared folder on the active-system outside from ServerFolders (without dashboard). After creating i’ve run the command \active-system from passive system -> no results. It’s still the same.

My ClientPc show it correct. This new folder is also listed in the dashboard.

what the f***k …

Could your program accidentally be picking up the folder and moving it to root?

You say from a client \server shows properly?

At the server if you do \server does it also show properly?

serverfolders is not a share, so it should not show.  Shares should be created from withing the dashboard :slight_smile:

I have no clue what samba is or does.  (it Googled Linux)

The only new thing in the update you might try is to set the Starwinds ICSIS service to disabled.  Stop it first then disable it in services.msc  Perhaps it conflicts with Samba

Hallo Gramps,

I have no clue what samba is or does.  (it Googled Linux)

sorry, with Samba I mean the simple windows network share (SMB).

serverfolders is not a share, so it should not show.  Shares should be created from withing the dashboard

yes i know. Please take look to the images for better understanding. (hope you can see)

client_view.png

This is the view from a clientsystem (to the active system) -> it shows properly

passive-sentinel.png

And this is the view from my passive-sentinel (to active sentinel). All my shared folders (from pic1) will shown as subfolders, when i’ve executed the command \active-system and go into networkshare “ServerFolders”. (Hope you understand).

The only new thing in the update you might try is to set the Starwinds ICSIS service to disabled.  Stop it first then disable it in services.msc  Perhaps it conflicts with Samba

This was a great idea, but it doesn’t change anything.

Your first picture has showed up, but I cannot really see it.  Can you post all your pictures to a publuic skydrive perhaps?

yes, please see here again:

  1. http://rhia.de/images/wd-forum/active-system-folderlist-from-dashboard.png

  2. http://rhia.de/images/wd-forum/client_view.png

  3. http://rhia.de/images/wd-forum/passive-sentinel-view-to-active.png

Thanks for helping