Network problems on LINUX SUSE server


#1

I know there are alot of issues regarding the 3-4 minute dropouts when using SMB. Most of them are using some kind of Windows to share their files. However, I am using a Open SUSE 11.0 server as a base of operations for my share. (My network also consists of an XP-installation).

I think i’ve tried all the tricks found in this forum but I cant get it to work.

Problem 1. 

It takes a few minutes after I boot the WD until it finds any share at all. 

Problem 2.

It gets stuck in some folders for like 30 seconds before it can read the contents.

Problem 3.

After 2-10 minutes of any movie, it cant find my network anymore and I have to wait like 10-20 minutes before being able to access the shares again.

Facts

  • the SUSE-server acts Master Browser according to browstat.

  • its not always 3-4 minutes, it can be 20 seconds or 20 minutes.

  • the movies are streamed (using a standalone bridge) wireless.

  • ive tried different permissions on shares but since the WD plays the movies it cant be a permission problem? 

Please, anyone using a linuxserver who might have some ideas of howto get this working?


#2

Anyone using linux at all?


#3

Update, I switched to wired instead of wifi and all of a sudden everything works like a charm, even the shares show up imediately after booting the wd live.

However its very weird that even when I have the wifi router and bridge five feet apart the problems occur, and its a 802.11n. 

Any ideas?