"network password" issues. A possible work-around?

Windows 7 Home premuim 64 bit. I had problems accessing the drive using “WD Quick View” then clicking on “open”. I had problems trying to access drive via “computer/network” then clicking on the “MyBookLive” icon. I couldn’t even map the drive using windows or WD Quick View. Every effort was dead-ended by the “network password” dialog box. I read through every post in the forum after searching the forums for “network password”. All these problems from all these users and WD hasn’t got a fix yet?? I noticed that some attempts to access the drive were met with a “Enter Network Password” that said “Enter your password to connect to:MYBOOKLIVE” while others told me the name of whichever of the three computer that I tried rather than “:MYBOOKLIVE”. Trying to map the drive using WD Quick View was a waste of time also. It kept trying to map \MyBookLive\public. I updated firmware and updated WD Quick View. I tried quick and long factory reset, the reset button, reset all computers and my modem and router. I researched, cursed and took some aspirin. Nothing helped. Then it hit me.

Open IE or use the “Run” command. Type “\\username”. Do not include HTTP or anything else in front of the back slashes (above the enter key) and don’t use forward slashes. Username will be whatever you set up on the drive.

NOTE: The IP address of your device will likely be different. One way to find it is using WD Quick View/dashboard. It will open IE (or your default browser) to http://NUMBER. That is the IP number of your device. Change the “HTTP://” to”\”, hit enter and wait a minute. This time the “Enter Network Password” will say “Enter your password to connect to:”. Now enter your username and password that you set up on the device. As soon as you get access to it, create a bookmark, or better yet, a new shortcut on your desktop.

After doing all of this, I now have a shortcut on my desktop that will open my folder on the WD drive. I also have a couple of worthless icons in my network folder. One is under storage. the icon looks like the drive itself and is labeled MyBookLive. It opens the user interface only. I can’t access the drive or any folders using it. It goes to initially then changes to add “/UI/” quickly afterwards. The other worthless icon under Network is showing a computer icon under the computer section. It is labeled “MYBOOKLIVE” and it goes to the “Enter network password to connect to:MYBOOKLIVE”. I can’t change either of the destinations to : but if anybody knows how, please tell me. Also note the then “Open” function of the WD Quick View will not open the device either as it also goes to the password dialog box to connect to :MYBOOKLIVE.

Next problem is that the IP isn’t static and will likely change…

WD – tell us what we are doing wrong to have to go this route to get access to our pricey devices please.

And you said I could back up my computer using this device with Windows 7. Windows 7 tell me that none of the home versions allow backing up to a network drive. Am I missing something here also. I know there is software to facilitate this but I would rather use Windows rather than installing more software.


Try using WD Link to access the dashboard and also to map the my book on any computer. Since you have Windows Home edition, it wont let you use windows backup on a NAS, but you can use Smartware to backup your files. 

WD Link




Hi n2guns

This is really brilliant - I had been struggling with this a lot but your workaround has also done the trick for me, thanks!

I am amazed to experience such problems with a relatively mass-produced product but at least it works now - hope others will find this thread as well.