Network connection via USB network adapter disconnects / drops frequently

Hello folks,

Network connection with my WDTV Live Hub has been working perfectly with an ASUS USB network adapter but after upgrading to Firmware version 3.09.18, the connection drops frequently and the only way to get it connected is to pull the USB dongle out and insert it again to the USB port. I tried checking the network status on WD TV Live Hub settings and it sees my network except it has zero signal strength at all when every other device in my network is connected and having no issues staying connected. Has anyone experienced this? I’m kinda getting tired of always having to pull the USB dongle in and out to get a working network connection.

Any thoughts? Thank you so much in advance!!!

The only answer I have for you is the one I hate the most, and see advised here far too frequently. For straight troubleshooting methodology, I would rollback and stress test your setup on the previous Firmware that you were using without issue. If that works well and then when you upgrade again you run into this same issue, at least you can guarantee that this FW version has something to do with your problem and not a different issue that by coincidence happened at the same time you upgraded ( USB dongle gone bad, Router assigning an address already in use etc). Process of elimination is always a good way to start with and issue like this.

If you are unclear on how to rollback to a previous Firmware version, a quick search of the forum will pull up plenty of information.

Good Luck


I would try a reset before rolling back. Its quick and easy.

Wow! How effective such a simple solution is. I think it worked. With the problem, it used to stay connected for only a few mins to an hour. So far the hub is still connected to the network after the reset to factory default this morning. Will continue to monitor. Thanks so much!

Well, damnit… After the whole afternoon it just got disconnected again. :frowning: I have two USB network adapters and I tried them both so I don’t think it’s a broken dongle. Should I try downgrading the firmware next?

And by the way, any way to unaccept solution and mark the thread as unsolved?

I was hoping the new update would fix this but sadly, nope. Would a downgrade do better than an upgrade to a newer firmware? Thanks again folks!

If you are completely jammed up, and tried the reset from above, can’t hurt to try the last FW that you had it working on. At least you will know if it is the FW and not the adapter.