Network connection stopped working WDTV Live Plus

Over the past week or so, I’ve been having an intermittent problem with my WDTV Live Plus not connecting to my WIRED network consistently.  Now the problem is constant.  I just can’t connect and the WDTV reboots itself very often while I’m trying to do so (it also sometimes freezes, rather than rebooting, but not as frequently)

When I try to connect to the network automatically, I get an “Unable to Obtain IP Address” error.  When I try to connect tot the network manually, I get a “Incorrect DNS Server Address” message when testing the connection.

The manual settings that I used are:

IP             -

Subnet    -

Gateway -

DNS        -

My router (Verizon Fios MI424WR) appears to be seeing the WDTV Live Plus at with a name of “new-host” and a status of “inactive”.  If I remember correctly, it used to see it with a name that actually described it (I don’t remember if is specifically said WDTV Live Plus or not).

Nothing has changed on my network and both a DVR and Blu-ray player that are conencted to the same switch are having no network problems.

I don’t know where to turn.  I’m assuming that the rebooting problem is related to the WDTV trying to connect to the network, but I don’ t know if that’s a valid assumption.   Today, when I tired watching something that’s on an attached hard drive, (after at least 10 start-up reboots)  it rebooted 10 minutes into the movie.

I have to believe that the problem is the WDTV, bacause I can’t find anything else that could be wrong.

Please help.

Edit - one last thing, I’ve tried pinging the WDTV from my router.  The test failed.

Update - after some more tinkering, I changed my subnet mask to and can now connect to the network.   I can see and use Internet Media and  I can see all of my ohter devices in Media Servers,.   However, when I select Video/Network Share, I still get nothing., the screen just stays on the Network Share Icon.

It appears that I’m heading in the right direction, but I’m stuck at another roadblock.

I ran into this problem using a FIOS router, and I have know the fios routers are ■■■■… however I found a fix that works.  First you have to manually configure the network. Create an ip address that won’t be likely to duplicate, I used, not you cannot use any ip address on a fios router between and as they are used by the set-top boxes.

Then use the standard subnet mask

and the gateway

Now here is the change, do not use the internal DNS, it’s ■■■■… instead I use Google DNS, it works, even if Google does track it.

So in the DNS field put

After doing this I appear to have full network connectivity on my windows 7 and vista computers, and full access to internet media.

Interesting stuff.   I have FiOS 40/40 service, and have none of the issues you describe.

I use the network / 255.555.255.0  on my network  (it’s faster to type.  :) )

I *DEPEND* on the internal DNS of the FiOS router to run my network and DHCP services.    Most of my devices are STATIC DHCP, and I have, at last count, about 25 devices on my network.    The internal DNS works just fine.  

I am using an Actionec MI-424 Rev D, with the latest firmware of course.