Network connection issues with WBL and Win7 - Windows Security credentials rejected

Hello,

I am running Windows 7 64bit and have a WD My Book Live 2TB installed in my network.

Currently I experience the following behavior with the NAS:

When trying to access the storage in explorer view in any way (typing: “\”, “\\public” or when using a shortcut created by some WD Software (don’t remember which one - the shortcut is labeled “My Book Live Public Share” and points to “file://192.168.1.2/Public”) or via WD Quick View options): a Windows Security dialog pops up asking for user and password - but no matter what I enter (used all users in the MBL settings, even added new ones to try), the dialog just reappears again.

Additional info:

  • I can access the config via web browser, no problem.

  • The drive is visible in the “Media Devices” tab in the network view. When activating, the Twonky Media browser view opens.

  • WD Link sees the drive, BUT does not see any shares, therefore the “Drive Map” portion is empty and the “Map Drive” button greyed out (yes, I have selected my drive in the list).

Strangely enough, all seems to work fine on Windows XP (didn’t try WD Link before) and it used to work as well on Windows 7 up until now, so I have no idea what could be wrong here?

Hi, did you tried admin/admin, or guest/guest for the username/passowrd. You can also try to leave it empty and click accept.

Unfortunatelly none of the above work.

I tried user settings from wbl as well as local windows login data.

It just denies access (re-pops the dialog 3 times, then errors out with "Windows cannot access ").

Really really really frustrating.

:confounded: Check if the link below helps, but I’m starting to think your antivirus/firewall might be causing the problem, try to disable it.

http://support.microsoft.com/kb/2669244

Firewall and AV have been disabled for troubleshooting from the start (I will check for viruses later on, but highly doubt it to be the cause).

I’m afraid, I cannot do much with the Microsoft help article, as I have no means of changing permissions (as I have no access to any file). I tried to check permissions on the shortcut, but got this message when trying to change to the security tab (which I find odd as I rather expected to be prompted with the credentials dialog, if anything at all):

Just for reference, when I unplug the NAS and use the shortcut, it goes straight to the “Windows cannot access” message and does not show the credentials dialog (therefore I would rule out issue #2 and #3 of the windows help article). 

So basically I have no permissions to the public shares of my NAS, even though I am supplying the admin password.

I tried another Windows 7 machine in the network, no issues there (and as I said, no issues with XP on my workstation either). 

I will dig into the Network and Sharing Center as this is most likely the issue here.

Some progress, but yet again more strange things.

I have changed various policy settings, deactivated password protection in the Windows Sharing Center, reinstalled network drivers, made sure I am in the same workgroup as the nas - none made any difference. 

But then I installed WD Remote Access ( https://www.wd2go.com/login.do) on my NAS and there has been some development since.

Using the web interface I can open my shares in explorer view (the app adds the selected share as mapped network drives to my computer). 

As soon as I do this, I can access the shares also through my shortcuts, but only those with an IP, not the device network name (i.e. “\192.168.1.4\public” will work, “\hdd1\public” will not).

After restart, all is gone though and I have to repeat. 

Now the worst part: 

The drives mapped by the remote access app show as the same disk size values as my system drive:

wd_disks.png

Could be considered a display error, but when I try to save a file to the drive, bigger than the free disk size (on my C drive) it tells me:

wd_copy.png

Deleting files from the NAS won’t make any difference, freeing up space on the system drive will.

Worse yet, some (most) files now cannot be accessed properly. 

Mostly its large files, but it is inconsistent - at first I thought files larger than 4GB don’t work (which I assumed to be a allocation issue), but after the first reboot I now can access almost no files (even 500MB).

It seems to be size dependant, but I am not sure yet.

This is how it behaves:

When I run such a file from explorer view, it starts in the appropriate software (e.g. media player) but immediately an error message occurs (Software dependent. Splash Player says: “Failed to open input file” whereas Media Player Classic outputs: “File not found”).

For files which do allow access, e.g. a movie, it takes an oddly long time to start (once started, jumping forward in the playtime does not cause a delay, so it is not a buffer issue). For a 1GB file it seems to be ~20sec, for a 3,5GB file 1-2 minutes (and as said above, it worked until 1st reboot, now no more).

What i can do is: view folders and delete files in explorer view and copy files to local drives via twonky media. Apart from that, nothing works properly.

The NAS shows in my network only as the IP, not the name (only after Remote Access).

I still cannot expand the entry to see the shares/subfolders in network view and I cannot access the base folder ("\" will not work without a share).

WD Link still does not list my shares.

I have run full diagnostic, but have no clue how to read the results.

I would evacuate my data and reset drive to factory defaults, but don’t have the disk capacity as for now.

At this point I don’t exactly hold my breath for any clear guidance, but I will keep updates in case I find a solution or someone has a similar issue in the future.