Network connection failure (904) using 4G

Hi
Cannot remotely connect using mycloud app to MyCloud (4TB) using Samsung S6.
When connecting via wifi on the same network it works fine, can access all folders, etc.
When I disable wifi and try using cellular 4g network I get the error - Network connection failure (904)
Also tried installing app on Galaxy tablet and get some error.
Can access MyCloud via S6 phone’s default web browser from the site www.mycloud.com using 4g but its not optimized for phones that’s why its important I get the app access working on 4g.
Have tried most suggestions from similar posts, i.e. have latest firmware v04.04.01-112, reinstalled app, turned remote access off and on, rebooted MyCloud, I’m the only user and administrator and have full access, etc…
MyCloud model is WDBCTL0040WT-AESN and was purchased new about 2 weeks ago.
Would appreciate any assistance

Have you registered your phone as a cloud access device for your MyCloud?

Thanks, I’ve generated an activation code and followed instructions as per http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10624 in the app. i.e entered the code and selected activate after adding McCloud device. It seemed to accept the code and took me to the next screen “Auto back up photos and videos”, which I selected the option “Not now” and then tries to connect without success and still get the error “Network connection failure (904)”. As it only allows me to use the code once I then deleted the unregistered user and generated a new code and followed the same procedure mentioned above without success.

Finally resolved the matter after chatting to WD MyCloud Level 2 support.
FYI - it was found that some ADSL service providers have port blocking set to ON as the default and you either need to login onto their site and disable it (set it to OFF) or contact them directly to do so.
A quick way to check if your internet service provider has port blocking on is to use this website http://www.yougetsignal.com/tools/open-ports/ and then type in either port 80 or 443.
Once again thanks to WD Level 2 support and the wd community