NetShare works then stop

Hello everyone

   I just picked up the WDTV LIVE and set it up with Airlink 101 N Adapter, Windows 7 x64, and NETGEAR WNR384 router.  The WDTV got wireless access fine and can see the Windows machine.  At first when I setup sharing, permission, and security on the Windows machine; everything works fine.  I can access mediaserver and Netshare to play movies from the Windows machine.  But when I turn off the WDTV unit and few hours later, I can’t access NetShare anymore.  But I still have internet access to Youtube and MediaSErver.  I don’t know what’s going wrong here.  But if I go to the Windows machine and re-do all the sharing, then it works again but later it won’t work?  Any help will greatly appreciated.  I’ve been searching and reading on here for a while and can’t seem to find the answer.  TIA.

This sounds like a Master Browser issue.

I have this problem if any of my Linksys E3000’s decide to become the master browser on my network.

The first step is going to be finding out which system is the master browser when it is NOT WORKING correctly.

On your PC, issue the command

net view

in a CMD window.

You should see a list of named systems.

For EACH of those machines named, enter the command

nbtstat -a (name)

Example:

Microsoft Windows XP [Version 5.1.2600]

© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\a0193633>net view

Server Name            Remark


\KIDS-PC

\MY-PC

\WDTVLIVE

c:> nbtstat -a \KIDS-PC

The NBSTAT command will show you the services advertised by each system.

ONE of those systems must have the service __MSBROWSE__ listed.

If there are NONE, or if there are MORE Than one, then you’ve found your problem.

Thank you for your fast response!  I’m currently at work and can’t do that right now.  But if when I got home and found out that there is none or more than one master browser then what should I do to fix it?  TIA.

I’m having similar issues: The WDTV Live+ will work perfectly for weeks on end – UNTIL someone asks for a demonstration – then it all goes to hell. Today a coworker dropped-by and it froze solid – I had to reset it. Since the reset it won’t allow access the media shares on my network. All the diagnostics show that everything is connected, I can view YouTube and NetFlix, but I cannot access the shares.

I tried following your instructions (my computer is running Win7) but was unable to get the command prompt to respond – I tried every combination of spaces possible c:> n, c:>n, etc. – in case I was misreading your post.

So I, too, am at my wit’s end.

Oh, boy…   Windows Newbies…  ;)     I’ve been accustomed to COMMAND-LINE stuff for decades.  I forget some people have never used them.

In WinXP

Click START,  RUN, and in the box, enter “cmd” without quotes and hit enter.   A (usually) black window will open with a command line prompt.

In Win7/Win Vista:

Click “Orb,” in the search box, type “cmd” without quotes, and the cmd icon will show in the list, click it, and a command line window will open.

That’s where you’ll enter the commands.

Actually, there is no “orb” in the “search box” in Win7 – one clicks “run” and then types “Cmd” to get a command line. What was throwing me was your inclusion of “c:>” in the instructions - so I assumend (when it didn’t work) that I was mis-typing the rest of the command string.

When I stopped adding “c:>”  it worked – but didn’t provide the response I desired: Nothing on the network showed as being the “master”.

BTW – I’ve been using computers since 1971 – and every MS OS since DOS-3.

You have been using computers since DOS 3 and you don’t know about the root directory c: and the typing of commands.

With all due respect that is nothing to brag about.

Plus Tony said that you click the orb and then in the search box you type cmd. You have to get to the search box somehow.

kerbe wrote:

BTW – I’ve been using computers since 1971 – and every MS OS since DOS-3.

Since you’ve been using Microsoft since DOS, you should have no problem figuring out the rest of your issue.

Sorry for missing the comma after “orb” – my bad, but I have vision issues.

I resented being called a “windows newbie” – I’m not a newbie – but it’s been YEARS since I’ve had to use CMD and, obviously, my memory of using it is sketchy, at best.

Using every CMD trick I could recall, I was unable to get back to the root: Win7 would not allow me any further back than the \user directory. Entering the command string you supplied identified the the devices on my network but, as I stated, neither was tagged as the “master”.

Now, where in any of this you took offense, I do not know. I’m sorry if I hurt your feelings.

The :wink: was intended to show that the comment was made in jest.   

Try shutting off EVERY device on your network except for your PC.

Reboot your PC.

At the very LEAST, your PC should be master browser.   If it is not, then there is something very wrong with it.

Ok – so the primary computer is the Master. Running nbtstat on the WD Live comes up with and IP address and “host not found”.

The WD LIVE +, btw, says everything is connecting properly. I did a factory reset, I did the push-the-button reset, I did the power-off for several house – but it still won’t find the share. It also won’t ask me for the share login.

so when you issued the command

nbtstat -a wdtvlive

gives HOST NOT FOUND?

That again means that your PC is not functioning correctly.  It says that because it’s not able to see the Host Announcements from the WDTV, and the PC doesn’t have any information on the host.

We can perhaps learn more if you run WIRESHARK (as explained in this post:   http://community.wdc.com/t5/Networking/How-to-run-WIRESHARK/m-p/33862/highlight/true#M3080)

and send me the resulting file.

About an hour ago I tried again – and, this time, everything was found.

I went back to the WD and tried turning every option in the set-up menu to off, then rebooted it. Then I rebooted it again and, lo and behold, it started asking me for passwords, etc.

And now it’s working perfectly again. As mysteriously as it stopped, now it’s returned. I think this is how religions begin…