Netflix issues, but not just WDTV!

There seems to be an odd issue with Netflix where some titles no longer will stream at X-High/HD (hit the OPTIONS button to see the streaming rate.) I thought it was a WDTV issue (I even backtracked the firmware), but it seems as if PS3 people are seeing it too.

More details on a thread I started here on AVSForum:

Odd Netflix issue

Thanks for the information…

Is this happening only with the x-high/HD?

Netflix worked great at my parents house on a Roku over the holidays.  Flawlessly on a Wii.  Got back here to watch something, and, what else, Netflix loading screen.

Netflix on a WD streaming player:


You shoulda taken your WD to your parents house to see if it worked there…  

I think the WDTV, like many devices, basically downloads the interface from Netflix. This is how features like automatic  ‘next episode’, Netflix for Kids, and suggestions when finishing a movie were added, without a firmware update. I wonder if the latest update is screwing something up at some level. It may be the cause of the hangs on the WDTV, or the X-High issue on several devices.

The X-HD business – I don’t have any idea about that…  I don’t particularly care as long as the picture looks good.  :)

But yeah, the UI elements are part of NetFlix’s HTML5 delivery.  The WD has a “WebKit” browser that displays the UI – and if it can’t load the elements from NetFlix’s infrastructure, all sorts of weirdness happens.  

All I know is that my kids were watching a Spongebob “marathon” most of the afternoon yesterday (Via a WiFi-attached Hub) and I watched several epeisodes of Law & Order and The Twilight Zone last night via a wired SMP – didn’t have a single issue – and never had had the issue Christian1 describes.

The only issue I ever had with NetFlix and WD was the bug (a LONG time ago) that the WD would ocassionaly forget the login credentials and you’d have to sign in frequently - but that was fixed quickly.

I just tried it again this morning – timing things.

Click NETFLIX – Took 8 seconds for the first action (Select your NetFlix Experience thing)

Make a selection – Took 3 seconds for my queue and suggestions to show.

Pick a show – Took 12 seconds for the video to start.

That’s par for the course – but on Friday Nights it can take quite a bit longer (double)?  Probably due to the load in NetFlix’s servers.

Just a note that this may not be as bad as it sounds. Apparantly Netflix has acknowledged that they are now using new encodes with new technology that allows the same quality at a lower bitrate. High/HD is now the 1080p feed, and Medium/HD is the only 720p (they used to be two different 720p feeds.)  X-High/HD is currently no longer used, except maybe for some titles that have not been udpated. Titles that were only in 720p to begin with will probably only show Medium/HD now.