Netflix freezes after 2.08.13 Firmware Update

Is anyone else having problems with the hub freezing while in the Netflix app?

There’s no recreatable steps to make if fail.  Certain days it runs fine…other days it’ll freeze in the middle of a movie…or it’ll freeze while going through the menu screens.

I’ve reported this to WD Support, although all they say is that no one has reported this problem…and that I probably just have a defective device…and that I should RMA it.

Does it EVER freeze in anything OTHER than NetFlix?

You can always check to see if other Netflix users are reporting problems. If the problems are random there is a strong possibility the problems are on Netflix end.


I don’t use many of the apps in the Hub, so far it’s never frozen in the Hub’s menu, Youtube, Pandora, or any other app.

It’s only frozen within the Netflix app.  

I stream Netflix, over wifi to a Wii & iphone without any problems.

The Hub is hardwired (gigabit) to a Netgear WNR3500L router.

What if you roll back the firmware since Netflix is most important to you for what I can read?


Thanks for the post.

I’ve tried rolling back to  Version 2.06.10, although that had no effect on the issue.  WD Support wanted me to move to the latest firmware…which hasn’t helped.

Something I’m going to try…I’ve been using a harmony remote to control the device.  Up till now I’ve always had the remote leave the WD media center part on.   So the media center would be left on for weeks at a time.  Only being recycled when a freeze occurred.  Today I updated the remore so now it’ll power down the media center when not in use.  

I’ll post an update in a few weeks, to share my results.

We’ll be waiting :slight_smile:

Netflix has frozen on me on every firmware except for the one it shipped with originally. (i don’t remember the version off hand, but, i did roll back to it once and it’s unusable , for me at least, since Netflix updated the interface.) It doesn’t do it all the time but it does it enough that I have to keep my fingers crossed every time I try and watch something on it. I have tried it on my pc many many times and it has never frozen on me there yet. I am considering another netflix ready device like a bluray player to use instead but I hate to spend more money on another device just for Netflix. I keep hoping WD will find an answer to this, (either a Netflix issue or a Hub issue) so that I can either enjoy the Hub or move on to something else. Been patient for a year now so I think I have been pretty reasonable. Fingers still crossed…