Need your help....2TB WD My Passport Portable Storage

I have a 2TB WD My Passport, but it does not appear at File explorer. It appears at the ejecting icon and Devices and Printers and at the properties says it is working properly…i’ve updated the drives but still not appearing at the file xplorer. Need your help please.

Hi mopmusic,

You can try following steps:

My Passport Drive Not Recognized

  1. Safely eject the drive
  2. Power OFF the computer
  3. Disconnect the My Passport USB cable from the computer
  4. Power ON the computer
  5. Log into the computers desktop
  6. Connect the My Passport USB cable directly to the computer. Do Not use a USB Hub

Drive Reformat

In some cases, an external drive formatted by one computer may not be seen by a different computer. For example: a drive formatted NTFS will be Read Only on macOS. Please follow the steps below if the drive was originally formatted on a different computer:

  1. Connect the external drive to the computer the drive was originally formatted on
  2. Copy or Backup the content to another device
  3. Format the external drive. Please see KBA 3865: How to partition and format a WD drive on Windows and macOS for more information (
  4. Safely eject the external drive. For assistance, please see KBA 15058: Safely removing the USB device from the computer (
  5. Connect the external drive to the computer that could not see the drive previously
  6. If the drive is still not seen by the computer, there could be something wrong with the computer or one of its components. Please consult with your local computer hardware repair services to assistance

Hi mopmusic,

I agree with James.G (WD staff).
But after trying the 1st suggestion please try my suggestion next before proceeding with his 2nd suggestion.

  1. Right click “This PC”

  2. Select “Manage”

  3. Go to Storage > Disk Mangement

  4. If the external HD is visible, check that it is both “Online” and/or “Enabled”

  5. If not visible, try using another data connector cable, and replace data cable if necessary

  6. Try inserting on other USB ports on the same PC and other PC’s to make sure that the issue is with the PC and not the external HD/SSD

  7. If steps 1 to 6 failed, proceed with James’ 2nd suggestion!