I am currently setting up the MyCloud Ex2 NAS for the use of iSCSI to our windows server.

This is what I did first:

wd help 1.jpg

And it came up with the following error:

wd help 2.jpg

I then thought about changing the “TB” option to “GB” see image below:

wd help 3.jpg

However when I do this I get the following error, I have since found out that you can only go up to 999GB’s using this option.

Any help on this issue would be greatly appreciated.

I am trying to make a 2.7TB iSCSI target.

Kind Regards,


Please check the following thread. It’s likely to point you in the right direction.

Sadly, that doesn’t fix it. If you put in a number over 999, it throws the second error. I have a new support case open.

Per WD second-level support, there is no workaround at this time. All we can do is ask for a future revision to the interface.