N900 cannot access Secure HTTPS with Windows 8

I connected a wireless access point (Belkin ) to the N900 router. I have two PCs - one running Windows 7 and the other Windows 8. 

With the Windows 7 PC, I have no issues - I can connect the Windows 7 PC to either the WD router’s 2.4 GHz wireless signal or to the Belkin access point’s 2.4 GHz wireless signal and can browse any website. 

But when the Windows 8 PC is connected to the WD router’s signal, if I attempt to browse a secure website (e.g. HTTPS:// www.facebook.com or HTTPS:// www.google.com), the website fails to load. The browser times out and nothing is displayed. I can browse non-secure websites (HTTP://…) without any issues, but not secure (HTTPS://…) websites. If the Windows 8 PC is instead connected to the Belkin access point’s wireless signal, then I am able to browse secure (HTTPS) and non-secure (HTTP) websites. I believe that rules out any issues with the PC browser settings. 

I have three browsers - Internet Explorer, Fire Fox, and Chrome. I have this problem with all three browsers.

I have tried various changes the router’s settings, but with no luck. I have removed the access point from the network - still no luck.

Any other suggestions?

Hello and welcome, see if the following link helps.


Unfortunately, no, the solution does not apply.  The solution discusses viewing a secure website using Windows 7 and Internet Explorer 8.  I am using Windows 8 and Internet Explorer 10.  The instructions cannot be followed, because Windows 8 does not have a Start Button.

Remember, I discussed that if I connect the Windows 8 PC to the Belkin wireless access point rather than the WD router, the secure websites would show up.  So I don’t think there are any issues with how I have Internet Explorer 10 set up, otherwise the secure websites would not show up while I was connected to the access point.  Also, this problem occurs with Internet Explorer, Fire Fox, and Chrome browsers. 

Thanks for trying.  Any other suggestions?

Hi  nukecity, please check your private messages. 

For my particular situation, in order to get the Windows 8 PC to read HTTPS sites, I had to set the router with the following configuration:

  • Enable (turn on) Guest Access
  • Disable (turn off) FasTrack Plus QoS

If either of these two items are not set up as stated above, the access to secure websites (HTTPS) would time out.

I spoke with Tech Support, and they intend run the same tests, and get back with me on their results.  

Kudos to WD for their Community Support and for the Customer Support.