N900 2.4ghz network drops Internet but 5ghz ok

Bought an N900 the other day and everything worked great right away. However the next day I noticed one of my devices on the 2.4ghz network was connected but the Internet didn’t work. My laptop on the 5ghz network was fine though. After a restart everything was fine for an hour or so but then dropped again. I reflashed to the latest firmware (had already been on 1.07.16) but had to leave my house after 15min or so and haven’t been able to test but assuming the same results. Any ideas?

Hello and welcome, 

Try resetting the router back to factory default and to see if that helps.  


Thanks, I tried that already and it works for 30-60min and then the same thing happens.

See if using a static IP helps. 

Do you mean a static IP for all of my devices connecting to the router?

Oh, forgot to add. I returned to my router after being away for the weekend and my devices were working fine. However, after about an hour or two the internet no longer worked on anything connected to the 2.4ghz network. If I restart the router it works fine for 30-60min but then craps out again. The wireless signal still broadcasts and my devices can connect - however I’m unable to access anything, including the router admin page.

After browsing several threads on here last night I found a few posts related to the last firmware update that seemed to point to the 802.11B and A protocols not working correctly. I changed my settings to the following based on these threads:

2.4GHz: WPA2 Security (used to be mixed WPA/2); 802.11G+N (used to be B+G+N); 20MHz Only (used to be auto)

5GHz: WPA2 Security (used to be mixed WPA/2); 802.11N (used to be G+N); 20/40MHz Auto

So far I haven’t had the 2.4GHz network **bleep** out on me so I’m hoping these settings stay solid. Unfortunately I had to leave again so fingers crossed it works for everyone else using it at my house. It’s unfortunate that for something billed as such a nice, high-end router it requires this much effort to get working in a somewhat stable condition. I’m used to “set it and forget it” with routers where I only ever have to ocassionaly update firmware to solve small issues.

Good to know that you got it working, reply back to this thread in case you continue to have problems. :wink:

I appreciate the follow-up but are these “known” issues? As in, are these things that are being worked on for future firmware releases or are they considered random issues even though they seem to be plauging quite a few of the units out there? I don’t think it’s unreasonable to expect to be able to buy a router, update the firmware where needed and then not have to fiddle with the advanced settings just to get a solid connection going. I know that if I were to go out and buy a comperable Linksys/Cisco or ASUS router barring any defective device issues I would basically be able to do just that and not have to spend time on a forum figuring out the right mix of settings to get it working.

So quick update, after about 8 hours of usage today the router no longer connected to the internet. It still broadcasted the 2 network IDs and allowed connections but no internet was working. I’m going to fiddle with it this weekend but if I can’t get it working it’s going back and being replaced with something more reliable.

Hi SirChris, all of the common issues on the community are reported to the development team for future updates/fixes. Please check your private messages to continue working on your issue. 

I just set up the N900 NetCentral router, and having the same problem. 2.4 network seems to drop out after <1h, and can’t get it back. the 5ghz seems more reliable.

Will try some of SirChris’s settings - but sounds like it still didn’t fix the problem. I updated the firmware tonight - but no difference.

Am also a bit disappointed in signal strength. Old Linksys “g” router had better signal throughout house.

Anyone else find a better fix for the disappearing 2.4ghz network?

I also recently got this router and updated to the latest firmware. I have the similar problem where the 2.4GHz network drops. I don’t even have the 5GHz network on, as I don’t have any network adapters that use it. I thought it was the fact I was using a really old Linksys Wireless USB adapter, but I just got a new N one and it’s still having the problem. I too hope this isn’t a fluke, as I saw mixed reviews on NewEgg where I got the device. It was discounted quite a bit. Just hoping this wasn’t the reason.

I have the N900 router and experienced the same problems.  After reading many discussion on the net, I have decided to restore the firmware back to 1.05 and reset back to factory default. Then, in stead of placing it on the top of any hard surface, I hang it up by using the 6 Ethernet cables connected the the ports at the back of the router. This way allow better air circulation and lower the temperature on the top and bottom of the router. Three weeks have passed, I only have experienced one incident which wireless authentication was unsuccessful but every already connected device (wire wireless) was able to access the internet without problems. I concluded that my router, may be some of yours, having components that were failing the high operating temperature. If not the component fault, then, it is the thermal design of the router. So, I don’t believe any update of firmware will correct the problems.

I agree with manhong888’s assessment about the heat.

I bought the N900 router 6 days ago. I was getting dropped internet every 30 mintues. I could immediately get back online by switching from 2.4ghz to 5ghz.

Yesterday after getting annoyed by this for what could have been the 100th time, I went over to the router and felt that it was very hot. I turned it upsidedown to get some more air flow to the ventillation side and I haven’t had a dropped connection since.

I just had my router drop me, to where I had to power cycle the device. I went to go feel the temperature, and it was not hot at all. I have the router standing on end, so air can circulate over top and bottom. I have disabled my 5GHz network as I do not have any wireless devices that can connect to it., so I cannot tell you if that would have worked.

guys any update on this ? i got the same issue with all the mynet 900 i had, 3 of them.

does anyone made it work without loosing conectivity? 

matongax wrote:

guys any update on this ? i got the same issue with all the mynet 900 i had, 3 of them.


does anyone made it work without loosing conectivity? 

I would contact WD to see if they can help with this.


honestly, i dont wanna bother wd anymore, already had two rma replacements and the issue persists.

so im tryin to see if there is a workaround , a diffrent way to avoid that behaviour.

I’m not real familiar with the routers, so I’m not going to be much help.  I would just continue to research the boards to see if  you can find what you’re looking for, and maybe someone can chime in with some insights.

1 Like