n750 doesn't recognize my book world 2gb white light edition?

Just setup a n750 router and everything seemed to go smooth till I tried to access a my book world drive…no go, not recognized for some reason? I also tried running wd discovery and it says no network drives discovered? Everything worked fine with my old belkin vision router and I figured it’d be no problem to get it to work with another wd product. Any ideas what I did wrong or can try?

Try using WDlink instead.


I don’t understand your question.

The N750 doesn’t “recognize” anything.   It’s just a router with a built-in switch.

Exactly what’s happening (or not happening?)

Tried using wd link with the same results, the router works for everything else but won’t recognize the book world nas as being connected? “No network device found”

Tried powercycling the router and nas but still nothing, is there a way to reset the book world to factory settings? Don’t know if that’ll help but I’m willing to try anything at this point. There is activity going through the nas as the 2 lights on the network cable plug are on (green solid yellow flashing) I just can’t do anything with it.

DId you previously have your MyBook World configured with a STATIC IP?

If so, is that static IP within the same subnet range you’ve defined on the N750 for the LAN side?

Unless static is a factory default, then no. It should be set as DHCP

 It’s driving me nuts, spent a couple hours playing with anything I could thnk of to get it to work with no luck. I like this router so far and would hate to take it back because of this :frowning:

I have the same issue with my N900 and 1TB My Book World white, not listed as attached device so I can’t set it up as ftp.:robotsad:

I too have the same problem.  However, I reconnected my old Belkin router (and a new Belkin router) and the Book World was recognized.  I went into the WD Discovery settings for Book World and the Network Mode was ‘static’ with the address unique to Belkin - ‘192.168.2.*’.  I changed the Network Mode to ‘DHCP Client’ and click submit. It updated using the static information but it is in DHCP mode.  Within the next couple of days, I will repurchase My Net N900 and see if Book World is recognize. I will post the results.

Success.  I was able to map my Book World folders on the n750 and n900 routers. It does appear to be the network mode as the culprit on the My Book World.  The only way I know how to change this mode was to reconnect the old router then use the WD Discovery to change the settings.