N600 unable to connect to the Internet

We have an ANCIENT LinkSys router, which I tried to replace with a Belkin which was awful. So, having always found WD products to be fantastic, I bought the WD N600 last week.

However, after setting it up, it refuses to connect any of my devices to the Internet - laptops, mobile phones, NAS etc. The Internet indicator/light on the front of the router is on, and the Dashboard also says that it is connected to the Internet. But the network icon in the bottom right says that my network is connected, but has no Internet connection.

I have tried this on two different laptops, both running Windows 7 - have run network diagnostics through Windows, tried changing settings in the router but all to no avail. I am starting to think there is a fault with the device.

Can anyone help?

Check the connections…

Reset all the devices.

Check the router settings and make sure that the firewall is allowing the connections.

Check the user manual for the unit.


What you should know is that it may happen that your computers and other devices have been configured to get some info from your old router. As this info is provided from the new one but from somewhere else, this might be an issue. 

One of the most common problems on a Mac (don’t know if this is the same on Windows) is the configuring of the DNS provider. If your old LinkSys router had an IP address like “” or “” (which is to my knowledge the most common config) your computer might be configured to get the DNS conversion (which allows the internet connection) from this address.

Now, it happens that WD may be configured to assign addresses in the “” or “” range. So, if your internet config links to “” for DNS and your router is now at “”, then you won’t get any DNS conversion thus won’t be able to get any information form the internet despite the fact that you are connected. 

Please don’t ask how to configure or check this on Windows, I would not be able to answer that… If it’s on a Mac, I can help :slight_smile: