Myworldbook unresponsive - please help


#1

All of a sudden myworldbook has become unresponsive. I can hear it power up when i plug it in but the blue light doesn’t come on and the network adapter lights (green and orange) do not light up either. Any ideas?


#2

Do you know the model number of the unit? Is the light on the front blue or white? Also have you tried unplugging the power for about 10 seconds and pluging it back in?


#3

The light on the front is blue (when it works).

Yes, I have tried unplugging, waiting, and plugging back in. No luck. I can hear it power up, but no lights, no connectivity.


#4

Try this reset, if the light on the front are not coming on at all then your going to need to RMA the unit. Unplug the power from the unit. Push and hold the reset button on the back of the unit. While holding that plugin the power. Keep holding the reset. Wait 30 seconds and press and hold the button the front. After 30 seconds let go of both button on the front and reset on the back. Again if light on the front does not turn on then you need to RMA the drive.


#5

Is it single drive or dual drive unit ?

dual drive ( If its raid 1 setup) : try opening the case, take out drive b and leave drive a connected and try accessing it, if does not work, take out drive A and leave drive b and try that.

Single drive , so sorry! you may try different power adapter in case is not getting enough power, or RMA it . in case you have data on it, data recovery company is recommended


#6

this is happened to one of my drives.

it kept saying ouch, ouch, ouch.

so I gave it a little brake, by unplugging it for a bit and then plugging it back in.

also, i made sure nothing was trying to connect to it at the time.

hope you get urs up and running again.