MyPassport is not working after formatting

Yeah, I think I royally screwed this up.

When I first got the Passport, things weren’t working properly. Switched out the chord fora different miniUSB, and things seemed to be more stable.

After a while, the information started to be inaccessible - so I transferred what I could off of there.

I formatted (I believe in FAT32), and the software reloaded - I guess this is expected.

The last time I formatted it, I am 95% sure I fomratted in FAT32, and everything is gone - it is barely being read by the XP computer, not showing up in XP, Vista, or Windows 7 “My computer” as a drive. The best I can get is some recognition on the manage, and only on Windows 7.

When I actually used the WD SmartWare (my friend suggested it may be a software problem), it prompts me to reformat the thing. Go right ahead, I have no files on it…it says “There has been an error erasing your drive”, and won’t continue after 2 seconds.

It then shows me the homescreen, and the drive shows up as locked. What am I doing wrong? How do I unlock it if:

I never locked it

I never put on a password

Its files are inaccessible

In the drive erase, it says


To erase the drive:

  1. If you do not see a prompt to provide your password, then either:
  • Click the drive image above the  Drive is locked message on the Home tab to display the WD  SmartWare drive unlock dialog.

  • Start the WD SmartWare Drive Unlock utility by either:

    • Using your computer’s file management utility to open either the WD Unlocker VCD or the WD SmartWare VCD, depending on the hardware configuration of your My Book or My Passport drive and double-clicking the Unlock.exe file

    • Clicking  Start  >  My Computer  and double-clicking the WD Unlocker VCD or the WD SmartWare VCD icon under Devices with Removable Storage "


Edit: I felt I should edit this and add whatever information I could…

1.) The amount of space it is supposed tohave is 500 Gigabytes. In several ases, it is reading 2 Terabytes. Why? (And if I figure out the trick, and it doesn’t compromise the drive, you better believe I’ll post it. If it is an error, this is just another symptom)

2.) When I right click on My computer, and go to manage, it shows me the space is simply unallocated, something to the tune of “you must initialize this drive for use”, and fails to initialize. On my XP computer, it doesn’t recognize it at all in Disk managae.

3.) It is recognized by the control panel as both a USB device, and as a disk drive

4.) I believe its original chord was wobbly, and may have led to electrical short. How can I determine this?

I’m having the same trouble my passport is not working right I went to format it back from the manager but it clean  everything out  and now there not a thing on it not a thing how can I get the software that came with it

That happened to me once and a firmware update fixed it. It gave me the option to erase the drive and then it’s been working ever  since, so give it a try…  If that doesn’t help you then calling WD for a replacement is the way to go on this case.


Firmware is a HUGE popular issue with some of WD’s products, especially if you are trying to work with Windows Vista (uuuuggggghhhh… lol). As Vista “updates” your computer, it’s erases parts of different software or disables it. This issue can be solved in this case with a firmware update. Also if your computer uses “Smartware” there is a specific type of firmware update for you. I reccomend NOT updating Vista everytime it says it needs to update  or check with Microsoft and see if they may have fixed the updating issues with Vista since they’ve released Windows 8. If this doesn’t help see if your computer has a backup file from when your computer was working fine with your external harddrive. Hope this helps!

1 Like

Thank You I Got It Running Now I Have Tried Using The Updated For 3 Days First But It Would Not Work It Would Run For Hours And Not Do A Thing But Now It Working

I had the problem recently too. I download a converter from and put the end product on my external thats when my hard drive errors started happening. I feel your anger because like me you probably wasted alot of time to fix it. I don’t think FAT32 is the write format because I have read thats for smaller GB storage, not 500 GB. I think its supposed to NTSF format for large storage devices. By the way I tried looking for any good freeware but unfortunately none was available for recovery, I guess thats why they charge so much for recovery.

Unless you intend to use this on Windows and something like PS3 or a DVD player format it NTFS. FAT32 has a max file size of 4 Gig it’s also more prone to corruption.