MyPassport appears as CD; no free space


#1

I have MyPassport USB (1TB) with Windows 10.
But the device only appears as ‘CD WD-Unlocker’ with no free space.

When clicking, I can see the folders ‘Extras’,‘Locale’, ‘autorun.inf’ and 'WD Drive unlock.exe.
Status-Test and Quick-Test run without errors.

I can’t create a new folder nor copy a file to the device. (because of no free space).

How to change the CD-Status in order to store Data on the device?

Besides: I unlocked the device


#2

The volume that contains the Unlocker (and other stuff) is what’s called a vCD (Virtual CD). It is not writable, hence why you see zero space.

Look in the Disk Management utility (included with Windows 10) to see if you can find your drive there.


#3

In the decice manager the storage appears but with error: Device wasn’t migrated because of a partial or total ambiguity (translated from german).
What to do?


#4

Same situation. Drive is unlocked and passes all tests. Only available as the CD Drive. Where is the main partition? There is nothing in windows settings to address this. It would be nice to have a WD response here.
Anyone who has solved this. Sharing your fix would be greatly appreciated.


#5

I solved a part of the problem in assigning once a (not used before!) drive-letter to the CD-Drive. Then the virtual CD and(!) the letter-named device appear. I’m able to read and write when clicking as usual on the letter.
But encryption won’t run, because WD Discovery always shows ‘no usb-drive found’.

I aggree to you that WD should make a complete response as there are lots of users with the same problem.