MyPassort Ultra wants to be formatted erroneously in case OS is WIN7 or 8. On a XP PC it works!


MyPassort Ultra wants to be formatted if it is connected to a  WIN7 and WIN8 PC. If it is

connected to XP PC, everything is ok.

WIN7/8: The drive can be opened (at least there is a message that it is open) but a window pops up

which asks if it should be formatted. The drive is visible in the drive list, but without a volume.

“Access denied” is the answer if I try it anyway.

XP: Everything works perfect . I have no complaint.

The drive passed Lifeguard tests. I have no idea what’s going on , but I need the drive urgently.

Do I possibly something wrong ? Can anybody help please ?

Thank you.


The problem has been fixed!

I got a hint about , that NTSF and NTFS is sometimes not the same. In my particular case , NTFS formatted by a

XP PC was not recognized by WIN7 or WIN8. So I tried it the other way around and now it works.

NTFS formatted by a WIN8 machine is recognized also by a XP machine.

I never noticed such a behavior before. Anyway, important is the problem has been fixed.