MyNet N900 router drops internet access on 2.4Ghz only

Several times a day all clients with 2.4GHz connections (iPhones, Android, Win10 PC, MacBook, iPad) lose the ability to browse. However, I can still ping Google and TWC DNS servers - it’s just the browsing that fails. No problems with the 5GHz connections. Rebooting or power cycling the router fixes things for a while.

I’ve tried telneting in and running the “mfc fan highspeed” command as mentioned in other posts. The temperature dropped from 58-60 to 42-45, but that didn’t solve the problem.

I don’t understand why browsing is affected but not other network operations like ping or tracert commands. I guess it could be that only certain protocols (i.e. http) are affected. Does anyone have any ideas about this?

I read all the posts here and tried various fixes but haven’t found a definitive solution to this problem. Since WD seems to have abandoned everyone on a sinking ship regarding their routers, I won’t feel bad about ditching this piece of hardware and avoiding future WD hardware purchases.

Hi, welcome to the community.

Have you tried re-applying the firmware of the unit? What have you done beside telneting the router? You don’t have any problem with LAN?

Hi,
I’m experiencing something like this since 2 or 3 months.
I have a home network with 10 or 12 devices (phones, tablets, computers. PS3, Wii, Chromecast).
Sometimes, I can access to Internet and sometimes I can’t but I still can ping websites.
If it’s not my computer then it’s an other one.
I restart the router and it’s ok for a few hours only or less. Computers loose Internet access every time.

I believe the issue with 2.4GHz was resolved with the router somewhere along the way, So . . .

It’s nice that the WD moderator told the other person to re-install the firmware. Problem is, clicking on Upgrade firmware in the router’s dashboard doesn’t work right (it says latest firmware is installed, even when it isn’t) because it is not publicly available anymore, plus they did not tell the person where to find it to download, and that is because it is not at a public link at WD site anywhere. But, it is still on the WD server.

Also, there are two versions of the N900 router. The one named N900 does not have a hard drive installed and the one with a hard drive is named the N900 Central. Be sure you know which model you have.

There is a website that collects and stores links to firmware, drivers, etc called DownDrivers. They have links to the location of the firmware for the routers that is at the WD server, so you know you are getting it from WD.

Here are those links to the final firmware for these routers, and download the correct one you need:

Wd My Net N900 Router Firmware 1.07.16
Windows All
http://downdrivers.com/down-driver-wd-my-net-n900-router-firmware-1.07.16.html

Wd My Net N900 Central Router Firmware 1.07.16
Windows All
http://downdrivers.com/down-driver-wd-my-net-n900-central-router-firmware-1.07.16.html

You need the user manual for the right router, and they are publicly available at WD Support for these devices. Look up the webpage for the unit you need when at wdc.com to D/L the manual.

Lastly, you HAVE to restore your router back to the factory defaults AFTER installing the firmware, then set up router up as if it were new, and instructions for installing firmware and restoring are in the manual.

Good luck with this, and report back on how it went.

1 Like

Thanks a lot for these links. I will try right away.

After a few days it seems to be the solution to my problem. It occurred only one time since I re-installed the firmware and I’m not totally sure it’s the same issue.
Thnaks!