MyNet M900 and external storage


I just purchased a MyNet M900 and set up was easy enough except I cannot see my  Iomega2TB Home Media Network Drive. It connects via an enet connection to the router but is not found by the MyNet 900. On my old Vizio router I just plugged it into one of the enet ports and it was recognized.

I have turned on the Enable as the Local Master Browser.




Have you tried using the WD QuickView to detect the drive?

Also note, that you should be able to map the drive manually using your computer browser. check on page 64 and 65 of the user manual

With the old Vizio router, how were you able to see the Iomega network drive? Was it through an Iomega program, or just Windows exploror?

Did you try rebooting the Iomega after swapping routers? It might need to refresh its IP information.

I have tried using Quickview to detect the drive with no success.

I was able to view the Iomega drive both through an Iomega program and window explorer.

Also I have tried hooking up a WD MyBook Live to the MyNet N900 router and it is not recognized either.

Could you expand on “not recognized”? Just to make sure I am following you.

What Operating System are you using? (win7/xp mac?)

How is your computer connected? (Wired / Wireless)


I am using Windows 7 Home Premium 64 bit as the O/S.

My laptop is connected to the router wirelessly and when I use the setup program it searches but does not find the drive.

Could you try attaching your laptop via a cable to the router?

This would identify if the router is having a problem with passing traffic from wifi to wired, or of something else it the problem.

I turned off my wireless connection on my laptop and connected it via the enet port from the laptop to the router and could not connect to the internet with the wired connection.

Just an fyi, the activity light on the back is blinking green showing active communication when connected to the router.

With the wireless off, and your laptop connected to an ethernet port, can you run a couple command from the command prompt?

Go to Start, Programs, Accessories, Command Prompt.

Right Click on Command Prompt and choose “Run as Administrator”.

  • From the command line enter


  • See what your IP address is, and write it down or something (to compare later).

  • Now type

ipconfig /release

  • Wait for it to release, then

ipconfig /renew

See if your IP address has changed, and try accessing the internet.

Just looking at your info so far, it looks like you might have a bad router. It sounds like anything that is connect by enet cable does not work. Is this correct?

Hi Chaos311,

After spending about 90 minutes on the phone with WD support I was transferred to level 2 support for about another 90 minutes. The tech told me it appears there was an internal hardware problem with the mybook and advised me to return it

for a replacement. 

I received an RA from the vendor and returned it to them today and hopefully will have a replacement next week.



Thanks for the follow up. . . that **bleep**. I Hope the new one works well.

Thanks, I did call support again just to check the router out and they said it appeared to be working fine.

Just to make sure, you’re not trying to discover the Iomega via N900 webUI storage page are you?

Do you see the Iomega unit on your DHCP table on the N900 webUI?

Make sure it’s using DHCP and that it’s getting an IP address on the same network as the N900 LAN IP.

Ex. If N900 is, then Iomega has a 192.168.1.x IP address. From there recheck if you can see the Iomega device from Windows Explorer. If you can’t see the device and know it’s IP address then you should be able to enter in 2 back slashes and then the IP address of the Iomega device to access it via SMB. Ex: // but with back slashes instead of //