MyCloudMirror visible for a few secs then disappears, so cannot use it

Bought a new MyCloudMirror, setup from website download, but could not get it to be seen by Windows File History or from File Manager. Pinging on IP address works, and I can login and get to dashboard, but in File Manager MyCloudMirror shows for just a couple of seconds then disappears for several seconds, then same again. If showing I can double-click and get to login OK, but cannot see any shares, on computer File History cannot find device etc. Dashboard shows no faults. Windows is version 10. MyBookLive 192.168.1.15 is connected to Draytek router 192.168.1.1 and computer is wifi on same network. Computer and MyBookLive both WORKGROUP. Firmware is 2.10.310. What is making it connecting and disconnecting so frequently? How do I get it to work properly?
Thank you, Michael

If you go into Windows Explorer and type \\\MyCloudMirror (or \\ followed by the MCM’s name if you’ve changed it in the dashboard) or \\ < ip address of the MCM > (replacing the bit in <>'s with the IP address of the MCM, e.g. \\ 192.168.1.15 without the space) does it then appear under the list of network devices and enable you to access shares?

It sounds perhaps like you have either a firewall or a WINS server issue on your network, although as you’re using Windows 10 there may be other factors in play as that does seem sometimes to do strange things regarding networking and SMB shares from some reports I’ve seen.

Thank you. With \\MyCloudMirror nothing is found, but with \\192.168.1.15 it only goes to the login page and no devices or shares. In File Explorer, opening Network usually shows the MyCloudMirror icon for a few seconds, then it goes, then sometimes comes back, then goes again… so on… Tried a Win7 computer, and from Network, opening the icon gives the shares (which is what I would expect). Now File History, which I used with the MyBookLive before it broke, cannot see a drive to backup onto. WDDiscovery only has Configure (which just goes to dashboard) and Create a Shortcut buttons active. I just want to use it for file transfer and backup, and File History for now, but cannot do this. I have found several reports of problems with Win10 and NAS devices which worked fine in Win 7 and 8. But haven’t found any solutions that work!

OK. To be clear, if you type \\192.168.1.15 into Internet Explorer (or Edge or Chrome or whatever web browser you have) it should take you to the dashboard log-in page, and if you type the same into Windows Explorer (the file manager) it should show the MCM in the network tab and then let you access any shares available in it. I’m not sure what you’re referring to by “file history”.

All of this is sounding to me like either your network is overly busy, your router is too slow, there is a firewall coming into play and blocking things and/or there is a slow or no WINS server on your network and so there is nothing keeping the list of SMB sharing devices on your network (so when you go and look, it has to hold an election as to who will hold the list and then compile it, by which time the original search has timed out and comes back empty or partly so).

Can you confirm the exact model of your Draytek router, and what your set-up is (presumably the MCM is connected to it directly via Ethernet, and how are you connecting your computer to the router?). Also if you connect the MCM directly to the Ethernet port of your computer with its cable, does it then show up correctly and stable under the network list in Windows Explorer?

Thanks Darren. Either \\192.168.1.15 or \\WdMyCloudMirror from a browser does go to the dashboard login page. In Windows Explorer nothing is found with \\192.168.1.15 or with \\WdMyCloudMirror. Opening the Network Folder goes to the MCM device icon being shown intermittently. Trying to open that, by catching it when it is visible, times out with nothing found. On the Windows7 PC Windows Explorer correctly goes to the shares when either name or IP is typed in. PC does not have an RJ45 socket, so it is connected to router by WiFi. Router is Draytek Vigor 2760vn with default firewall settings. MCM is connected to router Giga port. Network load is not heavy. On Win7 PC, also WiFi connected, the MCM shows correctly and stable. To me this suggests MCM and router are OK and points to a network problem on the Win10 PC, so I’ll have to look there. File History is the incremental version backup that comes with Win 8 and 10, and needs to see a device to backup to.
Thank you.

Did you find a solution to this. I have a very similar issue

As a test (and from something I read elsewhere on this board), try setting the SAMBA level on the MCM dashboard from Samba 2 (the default setting) to Samba 1 and see if that helps.

It’s under the settings entry in the top ribbon menu and then I think under network in the sub-menu (from memory as I’m at work, so if not have a look at the other sub-menu entries in the settings menu).

It works now! I found that when I suspended the computer’s firewall (ZoneAlarm Extreme Security) it worked, and when the firewall came back on it stopped. So I added the IP address of the MCM as Trusted and all OK now. Don’t understand why that was needed as the whole network is in the Public zone, so Trusted, but it works now. Odd, as on the other computer running Win7 there is no specific trusted IP address in the same firewall, yet MCM does work!
I did try other things like SMB 1.0, but File History apparently needs SMB 2.0 so I left that. Also I added a new value AllowInsecureGuestAuth = 1 to the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters following https://techjourney.net/cannot-connect-to-cifs-smb-samba-network-shares-shared-folders-in-windows-10/ and other sites I found. But that didn’t fix it, so I may remove the value but I think it is probably a bunch of connected things changed in Win10, so I might leave well alone as long as it does what I want. Darren, thank you for your help, and Dicky I hope this gives you something to try.

If it’s in the public zone then it’s explicitly not trusted, at least by the normal definitions used in such software. The public definition is you’re connecting to a network that’s not under your control and could have anything and anyone connected to it, so don’t trust it with raise as many shields as possible.

Anyway glad it’s up and running for you now. Put it down as one more ideosyncracity of Windows 10.

Whoops, my mistake. The local network should have been trusted, but all other networks are public. The router has a good firewall also which is what keeps the world at bay.