Mycloud very slow deleting files

WD appears to have removed that support article for what ever reason.

Because you are using OS5 firmware you may want to open a support case, if you haven’t done so already, with WD Support directly to see if they have any suggestions. Hopefully something more than just canned scripted responses.

Well, the fun continues (NOT!). I tried to go to my account to file a support ticket but it’s upset because nothing is attached (that was one of the steps for trying to make things work). So I turned on the connection. It sat there for an hour saying “updating”. Then says “indexing”. Great. Just what I was trying to avoid. After 3 days it finally finished creating the index! Now it says “generating previews”. Oh goodie.

Good news is that I was able to open a support ticket after connecting.

Bad news: no response after 3 days
So in parallel I just keep deleting files a few 10,000 at a time. It only takes 20-30 hours to do that.

What a ridiculous product.

OK - my final update. If you’re looking for the “solution” - at least in some circumstances - connect the drive to your wd cloud account and delete a folder containing the files in question. Poof! Instant.

That said - here’s the gist of the full story. I did get a response from a PERSON at WD. His initial response was “Please allow me to inform you that deleting or backing up the thousand of small files of will take time to be deleted from the My Cloud device because when you delete the file the My Cloud device remove and update the capacity again and again.” He said that I should move al the files to a folder then delete the folder. I was pretty excited about this UNTIL I tried to move them and ran into the same speed issue - the move was 0.35 files/sec. I did have a huge directory I could delete but that didn’t work (this is from File explorer).

So we went back and forth with me providing lots of info. Then his solution was to use an ethernet cable to connect it to my computer and try from there.
That was the last straw for me and I told him I was done with diagnosing their software problems and doing their QA. (and what kind of device says "don’t use this for lots of little files anyway!!!).
That’s when I decided to try deleting a huge folder from the cloud - which was very successful.
Meanwhile he did offer to have me talk on the phone with a “level 2 support person”. I’m not spending more time on this.

Oh - one more hint. When you connect your drive to their cloud it wants to index everything which may take days. During that time the drive may be so busy that you can’t connect to it from the cloud or see what’s going on. Just gotta let it crank.

Just so people are aware. The OS3 My Cloud devices running v4.x or v2.x firmware generally don’t connect to the WD Cloud account/system. Users running the latest OS3 firmware have the cloud features disabled on their OS3 My Cloud devices. That is likely why OS3 users don’t see the problem some may experience on OS5 when it comes to deleting large amounts of user data. Personally even when the Cloud feature of OS3 was working, never had a problem deleting a large number of files. OS3 typically didn’t experience the Indexing disaster/problems that OS5 users experience.


My limited experience with this is that most type of file operations done with a PC/MAC are across your local network, and much of the heavy lifting is done via the computer. If you are WIRELESS into the network - - - the data operations are limited by your wifi speed. This will work MUCH better with a wired connection to your network.

(there are ways to do this with the NAS doing the heavy lifting; but that involves LINUX commands over a SSH connection to the NAS)