MyCloud stopped working (permanent yellow light)


I have the WD MyCloud 3TB device which I purchased about 4 years ago.

I am running it using a Mac and used it via a wireless network.

I went on holiday for 2 weeks and when I returned noticed the yellow light was permanently on. My computer doesn’t recognise my device as if it doesn’t exist. I tried several potential solutions, none of which have worked, such as:

  1. Switched the device on and off;
  2. Disconnected and re-connected the network cable;
  3. Switched it off for a few days and tried it again;
  4. Used different network cables, and plugged it directly into my computer, among other things; and
  5. Switched it off, held the reset button in, and switched on and released the button after a minute.

None of this worked.

My gut says that this device is completely broken.

Please assist!

Have you tried a 40 second reset?

Is the network router issuing or listing the IP Address for the My Cloud?

If SSH was previously enabled through the My Cloud Dashboard can you access the My Cloud using SSH?

If you connect the My Cloud direct to a computer does the yellow light go away?

I did - no dice … unless im doing it wrong

Which LED is yellow? Have you looked at the User Manual, LED’s?

What, if anything, are the rear LED’s doing and their color?

Given the things you have tried, my gut feeling is the same. I think you may be looking at salvaging your data:

If this is successful, and the HDD is still working, you might try reinstalling the firmware, using one of the ‘unbricking’ guides.

If there is no activity on the network port LEDs, it is possible that the network port hardware has died; there have been quite a few reports of that problem.