MyCloud keeps disappearing off network

Yep

To enable SSH you must agree to void the warranty.

With this problematic device I’m not going to do that.

I read what is says. And, i actually understand it. I appreciate the splaining for someone as ignorant as me

But, excuse my skeptical perspective when I’m just a little suspect when I need to make a warranty claim that the honorable big tech company might use the one settiing I’ve run across in configuration setting that makes you agree confirm you clicked something that voids the warranty.

That is so unlikely to occur because all of them just want to do everything they can to satisfy their customers.

I’m sure that is your usual experience. On rare occasions i have experienced exceptions though.

I’m going to avoid the potential debate with them for now.

I do appreciate your help. If they tell me that is what i need to do to solve the problem and they document that the warranty is still valid because i did so at their direction, I’ll try it.

Sorry, i didnt mean to offend you and i now recognize that i shouldn’t have bought the cheap non-mercedes NAS.

I did not think that i needed a Mercedes NAS to simply stay on my network to serve music files.

I did foolishly believe that even a cheap NAS with redundant NICS and power supplies could stay on my network longer that my cheap non-mercedes garage door controller or cameras & doorbells.

Couple of more throw stuff at the wall troubleshooting suggestions:
Try putting a network switch or network hub between the PR2100 and the router it’s connected to. Probably won’t help, but with certain other My Cloud devices there was a specific conflict with certain routers and the My Cloud (see this link for more on that specific issue).

While an extreme last resort (if you haven’t tried it already), one should try completely restoring the My Cloud back to factory defaults including removing any third party add-ons like Plex and see if the issue continues. Complete factory reset is a standard troubleshooting method, but obviously not optimal when one has extensively configured a device.

Another extreme last resort would be to take the PR2100 to another location that has entirely different networking hardware and setup and attach it to that network and see if the issue persists.

One can try to get elevated support from WD (beyond their first line read the script people) and see if they can provide any help.

One can throw in the towel and either live with the issue (schedule a My Cloud reboot every few days) or move to using another brand/manufacturer NAS unit. Its entirely possible you just have a NAS that has become defective (for what ever reason). The price range the diskless PR2100 sits in there are a number of other similar dual bay NAS enclosures available from other manufacturers that likely have the same capabilities as the PR2100.

I appreciate the help. Status of your suggestions:

I had a switch between the LAN1 and the router for a couple weeks and LAN2 is connected through an access point to the router. The link you sent (I believe from OS3, I’ve tried a number of the OS3 solutions since my problem seemed more common on OS3) said specifically not to make the connection through a hub, only through a switch and I believe the ports on most access points act like hubs at the physical layer instead of a switch at layer 2 with full duplex. I’ll stick the switch back in between LAN1 after the next failure.

I just did this Thursday night and it dropped from the network within 21 hours. It was easy to do because my router is a dual WAN router. So all I had to do to was disconnect the patch cord for my back up WAN from my main router, and plug the NAS into my back up WAN router. Completely different network, different router, different IP range, etc. with no connections between the two. I did connect my PC to the wifi of the back up WAN so I could get to the dashboard but all other devices were physically and logically separated. Still dropped in less than a day. Oh, and my back up WAN never uses its router on my network, even when it is active. My main router still controls the network regardless of whether the router is using Primary or Back Up WAN.

I couldn’t find anywhere in the dashboard UI to schedule periodic reboots. Could you point me in the direction as to where to set that up? All I could find was schedule power which required power off for 2 hours, which would be fine. I set that up for a couple weeks. First scheduled power off worked fine and it came back up fine. Next scheduled power off didn’t occur at all. Third one powered down but didn’t power up. I turned it off after that.

As for moving to moving to another NAS box, I’m all for that, except I have hundreds of hours invested in my Plex Server. That’s why factory reset is off the table plus the problem started with the factory default settings. I don’t think it possible to just stick my RAID drives in a new box, is it? I could see buying another PR2100, saving the config file from my existing NAS, power up the new box, restore the config file, and insert my drives. That should protect my Plex configs and data, right?

Thanks for the continuing objective help.

Several options for scheduling a reboot. One is to use the My Cloud Dashboard Power Schedule.

My Cloud: Configuring the Power Schedule
https://support-en.wd.com/app/answers/detailweb/a_id/28312

Another option is to use a smart plug or smart outlet (or old fashioned mechanical timer) where you can schedule the on/off times for the plug or outlet that the My Cloud power supply is connected to.

Not sure if the multi bay My Cloud models support Wake-On-Lan (WOL). If they do that may provide another way to power on a multi bay My Cloud that has been powered down. Generally one can use SSH to issue a My Cloud shutdown command.

Its possible certain UPS devices may offer the capability to power cycle their outlets on a schedule or sent WOL commands to wake up devices connected to their power outlets.

This is such an unusual issue that it points to a defect in the NAS. If its still under warranty, just return it for replacement (don’t say anything about the change you made).

Good luck with the return.

Been working on an advanced RMA for a month. Back and forth sending pictures of the device label, receipts, credit card statement, remove drives and send images of thier labels.

They now have on their support website not only the NAS cabinet but they added the drives as two separate items.

Advanced RMA is designed so you pay for a replacement in advance, transfer your data to the new device and then return the defective item.

Problem now is their support site says you can only submit an an advanced rma for one item, which defeats the purpose of the advanced RMA if drives are separate devices and you can only submit an advanced rma for one item.

Since my cabinet is the problem, i thought, fine, replace the cabinet so i attempted to submit an RMA for just the cabinet.

Got the same error message in doing so that i did a month ago before the half dozen support chats and emails they required as hoops i had to jump through. So after a month of jumping through hoops I’m back where i started a month ago.

They have no intent in honoring their warranty, do they?

Anyone have an idea about how to get through the bureaucracy or should I just accept that the warranty representation is in essence fraud?

One can ABSOLUTELY migrate the drives to a new PR2100 box. It’ called “Raid Roaming”.

Now, if you really want to invest in another PR2100 box (vs say, a DS220+, or DS720+) is a separate question.

Agree that a Synology would be a better device but then he wouldn’t be able to use “raid roaming” and would have to reset up his Plex from scratch.