MyCloud is telling me I don't have an account with them

Hi all,

I went to and tried signing in with my email/password. Wasn’t working. Tried using my email address with the “forgot password” button, and now mycloud is telling me that there’s no account associated with that email address. (I’m 100% sure that’s my email account with mycloud. Have triple checked.)

Has this happened to anyone else? Solutions?

Sounds like the account is hosed.
But if all your data is on your local drive. . .do you care?

Any reason you can’t create a new account with that username?
You may have to “reshare” accounts on the local drive with the web accounts as a result.

I messed something up a few weeks back and went through similar excercises - - > It didn’t take long.

Have you checked the My Cloud Dashboard to ensure the user you are trying to sign in on has cloud access enabled and has the same email address you are attempting to use on

One can always resend the cloud access email via the My Cloud Dashboard to a new email address.

@mrangan34 As Bennor said, what e-mail address is showing in the Dashboard? See example image below.

Thanks for the help all. My account is back up and working today, and I have no idea what caused this.