MyCloud icon on Macbook Desktop

#1

How do I remove the icon from the Macbook desktop? Please note that I have already gone to Finder preferences, and unselected the “connected servers”. However, after each reboot, the icon shows back up again. I’ve called Apple support and logged an issue but they are stumped. My Mycloud drive is a secure device and I’d prefer not having it show up on my desktop.

#2

Hi DRunner4,

This is the feature of My Cloud Home device and it will appear on the desktop as it is virtually mounted on the Mac.

#3

you can through Finder setting hide the icon.