MyCloud I can't open it up in the Windows Explorer

Hey!
I just got a MyCloud 4TB Storage and I set it up by using the mycloud.com/setup webpage. But when I try to open it up in the windows explorer I get thrown to my local ip address where I can access the drive with a webpage. So how can I access the drive using Windows Explorer. Here is a screenshot of when I right-click on the drive.
Open the image

You are selecting the wrong My Cloud icon in Windows File Explorer. Look for the My Cloud icon under Network. Even better map the My Cloud to your computer…

https://support.wdc.com/knowledgebase/answer.aspx?ID=2676

1 Like

I’m having the same problem as Filip. Installed drive and configured WD Ex2 Ultra via web page. I can see it under Network / Storage but right click on it doesn’t give me an option to Open it. There is only “View Device Webpage”.
Noticed on other posts that it shows “Open”, and few other menu options.

If you are using Windows 10, one thing to check is if Microsoft disabled SMB 1.0. Apparently it may be disabled after a recent Microsoft update. WD Support has a knowledgebase article on how to enable SMB 1.0 on Windows 10.

Also ensure you have the network location set to Private.

https://tinkertry.com/how-to-change-windows-10-network-type-from-public-to-private

after searching i found the solution. it fixed this issue for me immediately.

go into your device manager and force update the drivers for the “mycloud”.