MyCloud has stolen my MyBook Studio external hard drive

Hello everyone… Help please!

I’ve been using a MyBook Studio for a while.
I recently connected it to my MyCloud, in the hope of transferring files more quickly.
I now wish to connect the MyBook Studio directly back to the Mac (ElCapitan). However, whenever I connect the Studio via USB, it’s hard drive does not appear in Finder. I can see it in Disk Utility, but I cannot read or write files at all.

It seems the MyCloud has created a Share for the MyBook and I can’t figure out how to get it all back to normal.
Is there any possible way that I can reverse this ‘Share’ whilst keeping all data on the MyBook Studio, and subsequently being able to use it as a direct USB external hard drive again??

Thank you greatly for any assistance.

When you removed the drive from the MyCloud, did you eject it first?

I’d normally say ‘check the manual’, but the manual is very poor on this topic… You can do it from the Dashboard by pressing the USB logo icon, and then pressing a very poor graphic that represents an ‘eject’ icon commonly found on CD drives: a bar with a triangle above it.

Removing before ejecting may have caused trouble for the directory function.

I should say that I don’t connect USB drives to my MyCloud, because I found the transfer rate to be pathetic. Others may have more experience.

Thank you for taking the time to respond cpt_paranoia, appreciate it.

You’re right, the transfer rate was abysmal, and ultimately I didn’t transfer much data in the end.

Excellent suggestion too (common sense that I had not tried previously- i did not eject the hard drive as I should have)… but unfortunately I still have the same problem. The MyBook does not appear in Finder… and I’ve tried the process twice, and restarted the computer both times. No joy.

Hopefully formatting is not the only option?