Mycloud EX2 Ultra not offering Shares after 40s Reset

I did a 40s reset on my EX2 Ultra to get the password back. I have a couple of USB externals attached and a number of shares. I can see the users, shares and External USBs on the Dashboard but when I scan the network the ULtra is only offering the HTTP service. Not displaying the shares and externals like it used to. I checked the Network settings against a second unit I have and everything looks the same. Any Ideas?

I think you have to reassign shares to users after a 40S reset.

All the data is there. . . you just have no users and nobody has access rights to the shares (until you fix it)

Check the Windows Protocol setting on the Network section of the dashboard, the default is SMB2,SMB3 and it may need to be changed to SMB1,SMB2,SMB3 in certain situations.

The process is Not Data Destructive and will not impact data on the drive.

40 second pin press will reset the:

  • Admin User Name (default = “admin”)
  • Admin Password (no default password, new password enforced)
  • Remove all Users except “admin”
  • Device Name Changes to Default
  • SSH (Secure Shell) User Name and Password (default = “sshd” no default password, new password enforced)
  • All Share settings (default = Public)
  • Automatic Firmware Update (default = off)
  • Network Mode (default = DHCP)
  • Remove all Alerts
  • Active Directory (default = off)
  • Cloud Connection (default = disabled)
  • account (default = not configured)
  • 3rd party Apps and Settings (default = no apps)
  • Backup jobs (default = not configured)
  • Windows Protocol (default = SMB2,SMB3)
  • NT LAN Manager (default = NTLMv2 only)

How to Pin Reset and System Only Restore My Cloud OS 5 Devices

Thanks, but alas no go. I have two units and have them in browsers side by side comparing each setting still no Shares displayed even after adding SMB1 2 and 3 on the not working unit. SMB1 is not selected on the working one. Still puzzled.

Just to be clear, the shares are located on USB drives attached to the EX2 Ultra, correct? If so, have you verified that user access for each share is enabled? Have you tried setting the shares to “Public” for testing purposes?

The shares are on the NAS plus the two USBs plugged in the back. Usually they show up in the list after http as a service.

The shares have been changed to public. Even the “public” share doesn’t show up.

Everything does show up in the dashboard. Looks like there must be some network item I am missing.

Bill Russett

Perhaps the following guide may help to solve your problem?

External USB Drive Will Not Mount, Not Seen or Detected by a My Cloud