MyCloud EX2 problems with displaying files in Chrome

I just got my NAS a few weeks back and initially was very happy w/ it. When I initially copied tons of stuff over from my PC to the NAS, it worked like a charm and I could see all files via mycloud.com via Chrome. Now I’m having problems viewing my files in Chrome. For example, if I choose “grid view” for a folder, it shows me whatever media is there. Then, when I go out to another folder, it shows that new folder I just went into as completely empty. I navigate to ANY folder at that point and it is empty, as though everything is gone. If I logout/in again, it is back to normal. So grid is totally messed up when using… Chrome? I tried the same in IE and it worked as expected, but… I really have no desire to use IE.

I also only see half my files in one of my folders now on the NAS when viewing w/ Chrome. If I zoom out, I can see more, but it won’t let me scroll down when at 100%…??? Either that, or it seems I’m forced to use IE. Again, no thanks. All seemed fine a week back. Was there some update recently that broke things on one or the other? Or does WD not mix w/ Chrome, or more specifically, MyCloud EX2?

Hi,

You can contact WD’s Technical Support about this.

To Contact WD for Technical Support: