date format

They are American format mm/dd/yy. Is this product designed for American use only?

Please fix this with localised dates.

Have you looked at the User Manual. Pick from what country you need it for. Hope this will help.

Did you try the dropdown menu? See image below. Click on, tap or activate image to enlarge it.


cat0w, selecting a different language on that particular page; first doesn’t address the OP’s date format issue once logged in. The date format remains the same (month followed by time). For example 11/27/15 12:27 PM. Second, for what ever reason after making a language selection (other than English) on the login page, once logged in the language went back to English for me even though I selected a different language on the previous page.

Royce_Lithgo, you may get better attention to your suggestion of having the option to select the date format by making it in the Cloud Ideas subforum.

I agree that we should be able to change the date format on

I have the correct date format set on the device, but always shows MM/DD/YYYY.

Ideally I would like to be able to sort the display of the files by date as well…