MyCloud can't connect via TP-Link Switch but works fine when connected directly to router

Hello,

so my MyCloud can’t connect to my network while being connected to a switch (TP-Link TL-SG1005D), but works without problems when connected to my router.

Working:

MyCloud -> Router (Linksys X3000) (-> Internet)

Not working:

MyCloud -> Switch -> Router  (linksys X3000) (-> Internet)

While connected to the switch the drive’s indicator light keeps blinking (indicating no network connection), the corresponding port-light on my switch doesn’t light up and MyCloud doesn’t show up in my routers connected (DHCP)Clients while my PC & notebook do.

My PC as well as a notebook connected via LAN-cable to the switch work without a problem. I’ve switched every cable & port around to see If thats the culprit but everything works in every configuration except my MyCloud.

I’m currently still on v3 firmware but that really shouldn’t be the issue for it working behind a switch. Any ideas?

Thanks.

I also am still using firmware v3 and have the My Cloud on a switch and all is working perfectly. Not to sound stupid or anything … do you have another computer or device to try with the switch? Have you reset your DHCP so it can find your switch? I am using a Linksys router with a Linksys SE2800 switch.

Just thought of something else … Has the IP changed when the My Cloud is connected to the switch? Can you check your routers DHCP Active IP Table? 

 do you have another computer or device to try with the switch

As mentioned in the first post my PC and notebook (via lan) work flawlessyl through the switch, internet and all.

 Has the IP changed when the My Cloud is connected to the switch? Can you check your routers DHCP Active IP Table? 

MyCloud doesn’t show up in my routers DHCP Table while on the switch but does show up when connected directly to the router.

Hm, are there any logs on the MyCloud I could look through via ssh to see what the device was trying to do while being connected to the switch?

Could be something to do with the switch being a “green” one.  It may not be supplying full power to the port.

WD could have fixed this issue with newer firmware.

I have the mycloud connected through a switch with no issues with FW V3 through several V4s

I do use a static IP which I suggest for any shared network resource but this shouldn’t be an issue unless the switch is blocking the DHCP protocol.

Could be something to do with the switch being a “green” one.  It may not be supplying full power to the port.

Probably, yes. I’ve been working on it and it looks like this is causing auto-negotiation to fail. If I run

"ethtool -s eth0 speed 1000 duplex full autoneg off"

then simply disconnect the cable from my router and connect it to the switch the device shows up again no problem.

Now as far as I know, to make this setting stick through reboots would be to edit /etc/network/interfaces so it looks something like this:

iface eth0 inet dhcp
    link-speed 1000
    link-duplex full
    ethernet-autoneg off

Which works, actually. After reboot the device manages to reconnect to my network. This setting though completely messes up the LED-Status light (it keeps blinking). Reason for this as far as I can tell is that WD initializes/sets the statuslight during ifup / ifdown events (specifically /etc/ifplugd/action.d/ifupdown) and this script and maybe others in /etc/network/if-up.d/ wont get called properly with the settings mentioned above.  

Is there a better way to turn auto-negotiation off permanently?

(I’ve found a way to fix the LED by issuing the proper command but I’d love to just configure it correctly).

Edit: I’ll be trying the static IP route in a bit after finishing a file copy.

Don’t ever set a link to Full Duplex manually unless you can set the other end as well.

If you can’t set your switch to full duplex manually, then you must use Half Duplex on the end you can set.

The issues are a little different for Gigabit, because most gig devices can’t even support half duplex, but your mileage may vary.

The switch supports both half and full duplex and both work without issue, the only thing that is happening now when I bring up my drive with this /etc/network/interfaces config the LED (and maybe some other things) dont get initialized correctly. The most obvious being the LED keeps flashing yellow even if the device is conected to the network and working

The flashing yellow light is probably due to the massive collisions caused because you have a duplex mismatch.

What I’m telling you is that if you set your Cloud the FULL Duplex, you’re effecitvely disabling auto negotiation, and the switch will not be able to detect the Cloud’s duplex setting.

 The flashing yellow light is probably due to the massive collisions caused because you have a duplex mismatch.

See edit As I said in my previous post, regardless if I use full or half duplex the issue remains the same. Yellow blinking light with working network access. 

This is related how WD sets the LED light and not wether or not the device has an active connection.

The issue has shifted from my first post and I’m now only trying to fix the yellow light:

  • My switch, probably because it’s a green one, causes auto-negotiation to fail (not enough power to port as suspected earlier)

  • Turning off auto-negotiation via /etc/network/interfaces results the device connecting correctly to the network and working

  • at the same time this setting causes the LED light to continously keep flashing yellow even though there is network access

Anyways, while writing this, I managed to fix it with a stuipid 50s delay before issuing the ethtool command by doing this

/etc/network/interfaces

# Configure Loopback
auto lo
iface lo inet loopback

iface eth0 inet dhcp
post-up /shares/ethtool.sh
allow-hotplug eth0

 

/shares/ethtool.sh

#!/bin/sh
sleep 50;
/sbin/ethtool -s eth0 speed 100 duplex half autoneg off;

Obviously ethtool.sh needs to be executable so chmod +x /shares/ethtool.sh for anyone reading this after a while, also if your network is capable of 1gbit you should use speed 1000 and not speed 100

The pause (sleep 50) is simply to make sure that all of WDs init scripts for lights/whatelse have finished running and are working properly. While this causes a slightly longer zero-to-fully-working boot I’m gonna take it since its working for now.

Edit: TonyPh12345 was right of course, half duplex, while you’ll be able to connect with full it causes a whole lot of colissions and severly degrades your connection. Thx Tony

1 Like