MyCloud blocks all permission to allow external network to upload?

I m trying to setup a file server where users can upload files into the NAS (MyCloud).

I started with hosting a website inside MyCloud but the WAMP could not allow me to add path thats pointing to the NAS, it says access denied.

So I decide to have the website hosted on my own server instead that is connected to the same network.
I had mounted the NAS to my server as “S:\” and I had also setup “FileRun” to provide an interface for users to access it to upload files to MyCloud, but whenever I try to setup the path to this “S:\” it doesn’t work, showing access is denied.

I tried it without the mounted path by using “\\MyCloud\Documents” still the same access denied message.

I tried to Symlink the “S:\” or “\\MyCloud\Documents” into a simple “C:\doc” and it shows access denied on the cmd.

I tried to setup FTP on MyCloud and access it from another PC that is outside of the network, I port forwarded it as well. The FTP connected from external network, user validation is good. But “unable to retrieve directory list”, FTP simply is being denied access to retrieve the directory or file list from MyCloud. (I can however have no problem at all doing it under LAN within the same network)

I am able to access directly from FileExplorer via the good old fashion “S:\” or “\\MyCloud\Document”.

I tried using setting up VPN (Hamachi) to allow external PC to join the same network and hope it allows the user to dump files into the NAS like every normal shared folder does, but the mounted “S:\” simply doesn’t have the feature to share. I tried to symlink that mounted “S:\” into “C:\doc” , well… it’s being listed and shows that the “doc” exist but when i tried to access it, it shows alert saying No Permission".

I know that I can just allow users to access and upload files, what I’m doing is essentially the same feature that they are offering, but there is one simple problem, a feature that’s not provided by the website.

The user is unable to bulk upload folders. It’s forcing user to upload files within folder by folder. If I have a lot of folders and sub-folders and a lot of files inside that sub-folders, I am required to create each of the folders and access each of the folders to upload files into it.

I am going through HELL right now with this MyCloud just because they couldn’t provide an option to bulk upload the entire folder that auto creates subfolder and store files in it.

Anyone out there has a better luck than me?