MyCloud 3TB freezes and loses pings

I just got a new MyCloud 3 TB, firmware 2.30.165. From the first moment I tried to access it either through a Windows map drive, or even its dashboard, I noticed that it freezes every once in a while and then resumes. This can be noticed while browsing the dashboard but most obviously when I ping it. From my Windows 10 PC, I start a ping -t and notice that it will reply to 10-15 pings but then timeout for several seconds and then reply again. The frequency of freezing is not stable. The device is connected to a gigabit switch using the cable included in the box.
Just for the record, let me say that I’m an IT professional with over 25 years of experience and I’ve done a lot of user support myself. So, I have tried everything to resolve this issue:

  • Configured a static IP for the device (yes, out of the DHCP range)
  • Tried a different Cat 5e cable
  • Tried a different switch
  • Tried pinging from different sources, even from my router
  • Have disabled DLNA, iTunes and Cloud access
  • Have done a full factory restore
    This is all happening without a single file copied to the device, it’s completely empty.

Any help would be appreciated
Thanks

You may have already looked at this, if not, maybe it will help.