MyCloud 2TB - stuck at white LED after botched package installation - need inputs

I am running a 2TB My Cloud on 3.x firmware. 

Recently, I attempted installing minidlna through apt-get.  Trying to get the latest version, I included Debian/Wheezy in the apt-get sources list.  This led to some packages being installed, which were not compatible with the build on the machine.  I ended up with many broken dependencies.  At this time, the machine was functioning. 

I then restarted the machine using the dashboard.  The machine never came back after this restart - it remained stuck with a white LED.  I tried waiting it out, but it didnt change even after a couple of days.  I then tried a system restore using the “40-sec” reset button method. The white LED blinked, but there was no further change.  I waited a couple of days hoping the restore would work, but havent seen any change.  I tried the system restore again, but there was no change - the white LED remains stuck.  All through, I am unable to access the dashboard.  I’m also not able to SSH into the device.

Any suggestions for rescuing the device would be very helpful.  I have a ton of data on it, and would very much like to retain it. (I know, I should’ve been more careful in the first place).  Any inputs / ideas would be much appreciated.

Hi qaqarox, welcome to the Community. This type of modifications are not supported, but maybe some of the other users can share some advice. You can also check the following links:

If you are unable to recover your files you can contact any of the data recovery partners on the WD support page.