MyBookWorld 1TB - Full restore?


I have a WD MyBookWorld Edition 1TB White Light. I have used it for about 4 years. It is attached by ethernet to my router and I have my early 2011 MaBookPro set up to back up to the WD using Time Machine. I also save some documents to the WD  in the public folder. 


In the Finder app I can usually connect to the WD drive and assess my public folder where I store some documents, but Time Machine is hit and miss. Most often it can not find the WD_Backup folder, or can not connect for Time Machine (even if I can see the folder in Finder). 

Lately the WD drive has not even been showing in Finder at all. i.e. it will connect and then later when I look again it will have vanished. 

What I have tried: 

I currenty have the WD plugged into my MacBookPro via ethernet to eliminate any wifi issues.

I have tried reseting the WD by putting a pin in the back. I have also turned it off and on again. Last night I tried deleting the sparsebundle file so that the disk is empty for me to start a fresh new Time Machine connection. That worked but the Time Machine failed to complete a new back up and I cant see the WD in Finder now. 


I would like to fully restore the WD drive to it’s original (empty) state and start afresh. Can anyone advise the best/simplest way of doing this. And also advise how to Find the WD in Finder when it vanishes? 

There is an option for resetting the drive via the reset button.

Other options are to factory restore trough the web interface, but since the drive is not showing you won’t be able to performed that way.