MyBookWorld 1TB Blue Rings overheating


I am an owner of a MyBookWorld Edition 1TB Blue Rings. Currently, i haven’t been able to use it or access it from any of my machines (a Windows XP Home Edition Desktop PC and a MacBook Pro 15.4"). In the begging i had an issue with my power adapter, but WD was kind to send me a new one (the original was lost). I tried with the WD approved power adapter and again the same.

Every few minutes (i would say between 5-10 min), the two blue rings start flashing together (according to the user manual found online, at WD official website) which means it is overheating and i should turn it off immediately. And so i do. But when reopening it, the same.

And during this time, i can’t see the drive from any of my machines (nor at finder on my Mac nor at MyComptuer at the WinXP-PC).

The firmware that the MBWE is running is the latest found, the 2.00.19 if remember correctly.

Any help please? Is it a software issue (maybe this version of the fw is wrong) or i have to send it to the service? Can someone help me?

Thanks in advance…

Since the question was added, there has been a small improvement.

I tried yesterday with only one of the two HDD’s, and i was able to see it from a Windows PC. But that’s it.

I couldn’t access the public folder, nor anything else. Just a test folder i created. And i tried changing the pw and reseting it.

The next thing i will do is to format both of the HDD to NTFS, and then insert them to the WD and format them allover again.

But, if i put both in and open it, it overheats asap.

Is there any solution to this?

I used my Windows 7 PC to format both of the HDD’s to NTFS, and now the WD is not booting.

Somehow the same as here:

And even though the disks are kind of hot, the fan is not working. But there are no lights flashing…

Any ideas?

The MBWE uses hard drives to store the OS. What you have done is like if you format all your drives in the PC and try to boot … the only difference is that PC has flash-based bios where MBWE does not have - it keeps everything on the drives … that are clean now …

I thought about it, but after i saw that the system is not booting.

Is there a solution to this? How can i fix it?

And if someone wants to change both HDD’s in order to put in bigger ones, what is the procedure in that case? Because what i am looking for could be similar (if not exactly) to mine…