Mybook World II - no mountable file systems

Hi guys,

recently, my mybook world 1TB was no longer accessible.

I tried time after time, but the connection probably timed out. 

Finally, I was able to connect, but when choosing the “public” partition to mount, I got the err msg “no mountable file systems”.


All my pics in there, of course. 
Warranty is expired, and so I removed the drive from the cabinet to stand a chance at data recovery.

Using Data Rescue III, I was able to clone the disc. This seemed best to do at once.

But of course also the cloned image (.dmg) is not mountable, and now I’m wondering how to overcome that.

Currently deep-scanning the image, and it seems to find thousands and thousand of files. Probably also old and deleted ones. Which is why Im hoping I can somehow make the image mountable so I can restore the initial directory structure instead of wading through millions of file corpses looking for my family pics…

Any chance of a few pointers? Is it likely I can somehow mount this file?

Disk Utility (I’m on a macpro) says “repair failed”, and that the partition map scheme is “Master Boot Record”. It shows the partitions like in the attached image. So there is information about the drive, but the question is how far can I go?

Best regards;




but as the post implies I’m more interested in knowledge than advertising.

I already Data Rescue 3, which works very well.




In order to access or mount the the file system of this unit a Linux system is required. The file system itself is EXT3.

HI there,

yes I’ve come thus far - I know about ext3 and tried using FUSE with an ext plugin for OSX.

That didn’t work either. It seems the most important partition (no.4) is damager.

However I’ve been able to clone it and resotore thousands of files.

Only problem is, I dont know if they’re all the files, plus they’re not sorted nymore, have no timestamps and no directory structure (which implied the sorting as directories had dates and names of events etc.

Using an Automator workflow including the Metadata extractor action (Google it), I have been able to extract dates from image EXIFs and create a sorted dir structure from that.

So I’ve come a few steps further. Still don’t know if I’ve saved everything, though. 

Guess I’ll find out when my GF starts scouring the new NAS for pictures <:-|

Tanks + cheers;