MyBook World II (blue Rings) not discovered after reset

I did a reset because I forgot my password and now I can no longer see the drive in my network. I see the assigned IP address in my router, I can ping it and it responds but that is the extend of the functionality. Cannot access it through the browser (mybookworld or wd storage or even the ip address directly) it does not show up in my network or even in device manger. I cannot find my copy of wd anywhere access and it seems to have disappeared from the net also. Please help I need to get to my files


Try resetting the unit again.

Also make sure to check if the routers firewall is not allowing the unit to be seen.

It’s been a REALLY long time since I’ve spun up a blue rings drive (To the best of my recollection, I think we stopped making them around 2010-2011), but if I recall it took FOREVER to actually start. How long after you plugged it in were you trying to access it? Have you left it alone for 30-40 min after plugging it in and than tried again?

I have disabled the firewall and all Antivirus, I have tried it on different machines, I have tried it directly into the computer bypassing the router ( after setting IP and subnet), I have left on overnight and left it off for 2 hrs, I have done multiple resets(10sec, 4 sec Etc.) nothing seems to bring this unit back to life. It all worked fine until I did the password reset. At this point I don’t know what else to do. Since I can ping the unit and get a response, I can only assume that the sofware is not loading.