Mybook World Edition froze during format


#1

I have had  a Mybook World Edition II (blue rings, 2x500gb) for about 3 years and when I went to format the drives and change them from RAID to spanned the device froze up.  After 5 hours of waiting and getting a message that said “Formatting In Progress…Please wait while this process completes.  If this page does not refresh, navigate back to the homepage…” and attempting to go back to the home page, I unplugged the device.  Today I tested the drives on my computer just to make sure they weren’t the problem and they both checked out ok.  So I put the drives back in the Mybook, I heard the drives spin up, but when I tried to power it on I got nothing.  I’ve tried the reset button and that didn’t get me anywhere either.  Any thoughts?

Thanks,

Darren


#2

A little update on my situation.  I’ve put the two drives in another Mybook World and that one won’t boot up either.  Drives spin up, but powering on doesn’t do anything.  Is there something I’m missing about putting drives into these units?  I followed the instructions in the manual…line 13 says “Reconnect the cables and power on the unit.”  My problem is that I reconnect the cables and the drives spin up, but no power on.

I confirmed the drives were good by reformatting them on my computer and transferring files back and forth on them.  After the first Mybook failed to power on, I took the drives back out to reformat them and noticed something strange; the B disk had one of the mybook partitions created on it and the A disc was still formatted FAT 32 from being in the computer.  Any ideas on that one?  I understand that the Mybook does it’s own formatting and on the Dlink DNS-321s that I have they just detect any new drive and prompt you to allow it to reformat…could the mybook just be more picky about the drives or the format of the drives you put in it?

Since I’m having identical problems on two previously working Mybooks, there must just be something I’m missing.  Thanks for any ideas you may have.