MyBook Pro II Enclosure malfunction

Hi there,

I’ve been using a MyBook Pro II 1 TB configured in RAID 0, with two 500GB drives, that I purchased in 2006, and it seems It seems as if the enclosure has broken. When I turn on the drive and plug it in via USB or Firewire, the blue ring (power indicator) turns on but It seems like no power goes to the drives - the fan remains off, the drives do not spin up, and the device does not mount. I’ve tried removing and reconnecting the drives from the enclosure, but nothing seems to work. I have no reason to believe one of the drives has gone bad, but even if that was a problem in this case, that wouldn’t explain why there is no power going to either drive.  Is it possible for me to remove the drives, connect them individually to my computer (mac), and access my data via a software RAID configuration (I think this can be set up in disk utility on a mac but I’ve never done it before)? A few other forums I’ve been browsing seem unsure as to whether this will work, and suggest contacting WD to see if I can buy a new enclosure to test them in. What are the chances that if the drives are fine, a new enclosure will help? I’ve sent WD an email but don’t know how long it will take for them to get back to me.



Are you sure the power supply is working right? There have been similar posts where that turned out to be the cause.


If by power supply you mean transformer, then I suppose I can’t be certain. The green light is on, and I’ve tried connecting it to several different outlets to try to rule out that variable… and by most indicators it seems fine. I’ve never heard of a transformer box going bad, but I suppose anything is possible. Clearly it is a power issue - the drives are not getting power. But I’m not sure how to determine if it is the transformer or if it’s the circuitry of the enclosure. I emailed the developers of the “RAID reconstructor” software and they believe that if the drives are in fact, fine, their software should be able to read the data so hopefully I’ll be able to use that as a last resort. I’d still like to try to either fix the enclosure, or find out if it’s possible to get a replacement enclosure from WD.

Can you post a link to one of the posts that had a similar power supply issue?

This could indeed be a power issue. The drive might be receiving enough power to turn on but not to spin up correctly.

Another possibility is that the interface is damaged and either one of the USB or Firewire interfaces are working. If that happens, then the drive does not recognizes that its connected to anything, and thus does not spin up.

I believe you should contact their phone support lines to see if there’s a chance to replace the enclosure and if that would work.

Your are probably right and you may have a defective enclosure.

I’t will be better that you contact Wd for a Replacement Unit, if your product is under warranty they will not send you an enclosure but a complete unit, so you will be able to test.  There is a users manual on their web site that will show you how to dismantle your WD Unit and take this two drives outside of the enclosure and put it in the replacement unit that you will receive.

Keep in mind that you have setup your Raid (Raid 0) and this type of Raid is fault tolerant, so if there is something wrong the data will be lost and the only way for you to recover it will be with a data recovery software.

If you disconnect both drives and then power up the enclosure, does the fan spin? If so, then this would suggest that one or both drives have a short on the +12V or +5V supply, in which case the fix may be as simple as removing a shorted TVS diode. It would also explain why neither drive spins up. In any case I suggest that you invest in a digital multimeter (~US$10), otherwise you are stumbling in the dark.

As for a software RAID, perhaps you could boot to a Linux CD and run mdadm:

You can also try connecting your USB or firewire cable to see if that alone is enough to light up the LEDs. Then switch on the AC adaptor and look and listen for any activity.

If I disconnect both drives and power up the enclosure, the fan does not spin - the blue light around the big button comes on, but nothing else happens. 

I’m not familiar with the operation of your external drive, but if the fan normally spins up as soon as you apply power, then the fact that it no longer does, even with the drives removed, would suggest that the supply voltage is not getting to it. You can probably determine the fan’s rating (+5V or +12V) from a sticker on its hub. Follow the fan’s wires back to the circuit board. There may be a fuse or protection diode in the vicinity.

Can you upload detailed photos of both sides of the USB-SATA bridge board?