MyBook Premium 1TB Not Working


I have a 1TB MyBook Premium which was given to me last year.  When I started using it, it was easily recognized by my desktop.  Recently, however, it stopped showing up in My Computer.  I tried connecting it to my laptop, with the same result.  When it is not connected to a PC, it seems to load fine (with a solid LED ring).  However, when it is connected, it stays in the “in Use” state with the lights rotating clockwise, and Windows never recognizes it. Also, it does not show up under Disc Management.  Both PC’s are running Windows XP.  Any assistance would be greatly appreciated.  I would at least like to get my data off this drive. 

Well my dear Mr. Malaya, it seems that your MyBook 1TB has fallen under the SSD curse.

Try to hear the delicate noises that your drive is doing, trying to spin: if they are rhytmical with a constat beat… I assume the drive can´t move the heads: that’s what happens most of the times, hence is not recognized by your computer. It seems that your data is still there but recuperating it may be expensive. Some advisors said changing the power supply may help… I don’t know.

If no sound at all… your drive is dead. Data may be there but again prepare yourself to pay good money.

Unless… your purchase a backup insurance at same time that you buy your WD drive. Here in EU this service is around 20-30€ three years term.  (You can find it @ big electronis retailers all around).

Still all my simpathy goes with you. Frustration is only the first step.  All the best! 


PS: SSD stands for Syndrome (of)Sudden Death. Common disease in babies and Hard Disk units.

Thanks anyway for the help.  I’ll try to use a different power supply, but it doesn’t sound like it will do much good.  The funny thing about it is that it only shows “in use” when it is connected to a computer.  I get a normal status as soon as I unplug it.  No, I don’t have the insurance.  This drive was given to me.  If anyone has any other suggestions, I would greatly appreciate it.

Is this a dual drive?  If so, how do you have it configured RAID 0 or 1?  If it’s mirrored, you should be able to pull one of the drives and connect it to your computer to get your data.  If it’s RAID 0, then I would try another power adapter, another cable, another computer, and if they don’t work…sorry. 

However, if you still have warranty on the drive, you might be able to do an advanced replacement and use the replacement case to regain your data.  However, I would definitely contact WD to see if this will work, and how you have to do it.

To Contact WD for Technical Support