Mybook live hangs my Windows 7 machine

Hi,

Since I introduced the new mybook live I have had the occasional machine lock-ups, basically the whole machine freezes, the UI can be seen but it will not respond to keypresses or the mouse.  The only thing I can do is a hard reset.

I can now reproduce the problem by using the config update feature.  In the settings I choose to update my mybook from a downloaded file, as soon as I hit the OK button, my machine locks up, every time I try.  I can’t see anything obvious in the windows event log. 

There are other scenarios which hang the machine, but I can’t narrow them down.  If I leave my machine on overnight for a big download, it will be hung in the morning.

Any help would be greatly appreciated.

Mike

To see if there is an issue with the MBL please try to access it from a different computer.  You may also check in your W7 machine if there is a security software, like anivirus or firewall, that could be interfering.

Hi,

I suspect it may be just this machine or driver related.  I have another win7 laptop which I have used to upload the firmware to mybook live, and that worked fine.

It’s hard to pinpoint the error as there are no event log entries.  The problem started when I introduced the mybook live.  I will try some further experiments, to see if I can reproduce the problem in different ways.

Thank you for the response.

Mike

Mike, did you get anything out of this? As you can see in thistopic, yesterday I installed the drivers on my Win7 X64 PC. Didn’t notice there was exclamation mark in Device Manager before so I checked in Windows Update and installed drivers from there (also for my WDTV Live).

Today, all of a sudden, my PC started behaving exactly as you say. It was hanging up and all I could do is to restart. Then it happened again, 2-3 times. I reverted back to a ghost backup I had, and so far it is working but I still get the exclamation mark in Device Manager.

If you or any other person can help, I would appreciate it.

As an update to that, I have tried installing driver from CD or through Windows Update. Every time I have the same issue. My test methodology is to have a norton Ghost backup of my system with all drivers being up to date namely

-Realtek drivers for the LAN Controller (RTL8111E)

-M/B (MSI A75MA-G55)

-Gfx card (I use the APU gfx of the A8-3850)

-Realtek Audio chip

Before installing the WD Driver, everything seems to work, but I get yellow exclamation mark in Device Manager and MBL is not listed under the Hard Drives. As soon as I install the MBL driver for Windows x64, the PC keeps freezing.

I can’t think of anything else. One question to tech guys: Is the Realtek LAN Drivers that the WD Driver interracts with?

The former works just fine with all devices so far. It has some advanced settings that I can play with but it seems chaotic to start changing.

Any help is appreciated guys. Alternatively, should I make a post in Network Drive Ideas?

I found what is causing the issue. When the driver is installed, either by the CD that comes with MBL (version of driver is 1.1.1.1) or through Windows Updates (driver version 1.1.2.1), PC keeps freezing.

I checked some of the services and noticed PnP-X IP Bus Enumerator Windows Service mentioned as a reason for crashes when people shut down their Windows PCs. By default, the service is set to Start as “Automatic (Delayed Start)” and this made me suspicious because Windows hang after some time and not right after I enter the desktop. 

Yesterday I installed all 3 drivers I was seeing available in Windows Update, for MBL, for WDTV Live and one named Microsoft Digital Media Server Module which is related to Twonky and how it collaborates with Windows Media Player (well, the later is useless for me since I never use WMP). As soon as the drivers were installed (I was not prompted for a restart) I checked Device Manager and saw that MBL was listed as a HDD. However, I knew that as soon as I restart my PC, it would hang.

dm.jpg

Therefore, I disabled the PnP-X IP Bus Enumerator service. Restarted and no hangs. Made 2-3 restarts and never had a hang. Of course, My Book Live Network Storage disappeared from the Disk Drives in Device Manager and Digital Media Device (Twonky) disappeared from Digital Media Devices.

For me it is clear that the combination of the WD driver for MBL (either 1.1.1.1 or 1.1.2.1) and PnP-X IP Bus Enumerator cause the PC to hang, probably when the PnP-X IP Bus Enumerator service starts under a ‘Automatic (Delayed Start)’ status. I will definitely post this to Network Drive Ideas but also posting the workaround here as a reference for users who may face the same issue.

I hope that if any WD people see this post or the one I will make in Network Drive Ideas can pass this to the driver developers so that they can provide Microsoft with a working driver.

1 Like