MyBook live FTP slow transfer

Hi All,

With my MyBook Live i can download files within my Lan with a speed of ± 25mb/s

But when i want to download a file with FTP over the internet it starts with 10kb/s to 0kb/s. All ports are open.

Does anyone have an idea what the problem is?

Please help!

1 Like

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

I dont believe this could be fault of your NAS device.

Mine works fine from/to ftp/sftp download/uploads.

To check ftp speed use this test file - ftp://94.75.223.121/speedtest/100mb.bin

It is connected to fast network in Netherland. Speed should be very high.

Thanks !

Im connected to a fast internet connection in the netherlands aswell.

Down = 120mbit up = 10mbit.

Port 21 is open.:frowning:

Will try to ask technical support, hope someone has another idea?

Just called technical support, they cannot help me, they say its my router, but my port 21 is open.

Can someone test from another location?:

ftp://83.84.94.117/speedtest/100mb.bin

@horcus: fix permissions.

wget ftp://83.84.94.117/speedtest/100mb.bin
--2011-03-22 18:09:16-- ftp://83.84.94.117/speedtest/100mb.bin
           => `100mb.bin'
Connecting to 83.84.94.117:21... connected.
Logging in as anonymous ... 
The server refuses login.
Retrying.

Hi,

Today i tried at multiple locations and didnt helped. Also bought a new router, because of the old one had some problems with other stuff. Still the connection drops to a few bytes per second. Ports are open, i really dont know what to do.

Anyone who can help?

Does speed also drop when you download something from internet in your MyBookLive using wget?

p.s. Ouch, I probably misunderstood you.

You are saying that download files FROM your mybook live using ftp over internet is slow.

First I was thinking that you want to download something from internet to mybook live.

oops, dont really know what you mean? How can i try?

hehe no, its downloading from Mybooklive to computer outside my lan.

Uploading outside my lan to ftp is good! Where i tried, i reached the max upload speed of the ISP.

I called Westerndigital, they cannot help me, the problem lies to my Router…:S (thats the only thing they say)

I called my ISP, everything is open, nothing is blocked.

Tried 2 different routers: Linksys wrt320n, and now Netgear WDNR3700, same problem both. 

Over the internet I cant find the same problem:( Is there anything i need to change through ssh? Or will enabling the FTP in the UI and open the ports be enough?

Pleas help…im desperate:stuck_out_tongue:

hmm, i DO HAVE same router as you - Netgear WDNR3700 - works perfect.

Only that I did not liked its default firmware (it was basicly quite unstable and even without ssh access to router) , so I installed dd-wrt , (that will probably broke warranty) , but i dont care).

After that everyhing is rock stable.

root@router:~# uptime
 22:27:40 up 102 days, 21:22, load average: 0.00, 0.00, 0.00

Ok, sounds fair. Is there anyway i can try without router? Dont know if i can connect to nas directly to modem. It should work without the wrt firmware right… Anything special you changed in your router? Or only forward port 21?

Did not changed anything special.

Just mapped 21 to other port. default ftp port attracts too many unwanted ‘hack-in’ attempts.

Im sure you can connect it directly to modem, it just then will use your WAN IP, not local LAN ip.

Hey, guys!

I have the same problem with speed over FTP via router (DLink-615).

Did you find solution?

no, i went back to the store and got  my money back. Support from WD itself is crap. Bought a new router, and got the same problem. I will check for another NAS but no WD:)

My first MBL was RMA’d because of burnt out led colours so this is my second unit  and as on the my original one this one also suffers from the same problem with very slow wan ftp downloads, 5 -7KB/s

I have tested with another ftp server on my network and top out my lines upload speed, 750/800KB/s

Transfers inside my local network are fine.

Ports have been forwarded and I’ve also tested a few other things but wihout success.

This must be some kind of vsftpd operation system intergration problem or maybe a version bug.

Please check into this WD.

Also the FTP server configuration page needs more options on the MyBook Live not just an enable/disable box which seems poor.

2 Likes

Just to chime to say my problem has been solved in the latest 2.00.35 firmware. The cause must have been that

MTU discovery problem.

Thanks WD team.

1 Like

Yes - you were helpful in getting the team to look into this.

What types of download speeds do you get now?

Glad I could help.

Getting around 65KB/s from a 1MB upload line, more or less what I would expect, could probably get a little more if I disabled QOS on my router.

Thanks

Gingernut:   You’ve piqued my interest.

MTU Discovery problem?   What’d you find?