Mybook Live doesn't connect at Gb on Gb-switch


Recently I bought a Gb-switch (Zyxel GS-105B). When I connect my MBL to it, auto negotiate will end up in a 100 Mb connection speed. The NIC in my pc will connect at 1 Gb when connected to this switch.

If I connect the MBL directly to my pc, it will set-up a Gb connection. So I know that both my pc and MBL are capable of Gb connections. it seems that the MBL somehow doesn’t recognize my switch as an Gb-switch.

I allready tried to force a Gb-connection by using ethtool, but this just freezes the MBL.

Are there more people with a similar problem? Or does anybody have a clue why the MBL doesn’t connect at Gb speed.

BTW: I’m certain it has nothing to do with the cables I use. I have been capable of setting up a Gb connection using the same cables.

I doubt it’s freezing the MBL,  it’s probably that the switch is not following the change to gig, so you wind up losing contact.

First thing I’d check is the cable;  make sure ALL FOUR PAIR are wired.   Four pair are required for gig, but only 2 are required for 10/100.

It’s rare, but there are still switches out there that don’t work with specific pieces of hardware (or vice versa)… 

The cable I use to connect the MBL is the original cable WD provides with it. If I use this cable to make a direct connection between the MBL and my pc, it will setup a Gb connection. I’m sure it is not the cable.

I think you’re right about the MBL not freezing but just loosing connection. I tried again to force the MBL to Gb speeds. If I do so with autoneg on, it will set itself to 100Mb. If I do with autoneg off, it will loose connection. For some reason autoneg does not lead to the highest possible link speed between the MBL and the switch. I’d like to find out why.

See if your friends or coworkers have a different switch you could try it on.  Just a data point…