Mybook Live 3TB is running, but I can't communicate with it!

Hello everyone,

I have been using a Mybook Live 3 TB for the last 6 months, and now, since 2 weeks, the disk has disappeared from the Finder of my Mac laptop, as well as from the windows explorer on my PC. The drive is still running, the front led is green and static (not blinking), and the 2 back leds are 1- green and blinking and 2- yellow and static. To my knowledge, according to the leds the drive should be ready to communicate with my wifi router, as it used to be in the past 6 months!

I tried everything I could think of: reboot both the Mybook Live and the wifi router, reboot my laptops, change the ethernet cable, change the ethernet port on the router… Nothing worked. I plugged the drive to my laptop through the ethernet port: nothing was recognized. I also tried the WD Link software: no drive was detected. When I go to the website (I enabled the remote access some weeks ago and it was working pretty fine), the site tells me that my disk is offline… In summary, the disk seems to be running fine, but I am unable to communicate with it.

Do you have any advice or tricks I could try to fix it? Thanks in advance!

Try pressing the reset button on the back of the My Book Live for 4 seconds.